1

This happens after I upgrade to 19.10 (from 19.04). When connected to an SSID with multiple BSSID (wifi roaming), the connection is fine, for the first few minutes.

Then when the connection switches/roams to another BSSID, the connection would drop. The nm-applet and iwconfig still show it's connected, but when I check "Connection Information", IP+Broadcast address and subnet mask are all "Unknown". Ping would say "network unreachable".

I tried setting the BSSID in the nm-applet, but it still roams to another AP. Whenever this happens, I have to re-connect. This happens in every AP (office/library/friend's house) I tried. No issue if there is only one AP (no roaming).

I also tried disabling wifi power saving:

$ cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf 
[connection]
#wifi.powersave = 3
# Disable wifi powersave
wifi.powersave = 2
$ iwconfig
wlan0    IEEE 802.11  ESSID:"FOO"  
          Mode:Managed  Frequency:5.785 GHz  Access Point: xx:xx:xx:xx:xx:xx   
          Bit Rate=270 Mb/s   Tx-Power=8 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=41/70  Signal level=-69 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:5   Missed beacon:0
$ sudo lshw -C network
  *-network                 
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 73
       serial: xx:xx:xx:xx:xx:xx
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.3.0-24-generic firmware=17.3216344376.0 ip=xxx.xxx.xxx.xxx latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:51 memory:e3500000-e3501fff
  • I'm experience a similar problem on Debian 10 while connected to a large apartment building's wifi network. If I walk around, I can trigger an AP switch and make my connection drop. I've also noticed, in journalctl, I get errors like "May 07 14:19:53 jeffzhao-t450 wpa_supplicant[538]: dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/1" – identicon May 7 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.