I am (linux beginner) trying to install Opencv on Ubuntu bionic 18.04, following this git shell scripts to install different version of OpenCV instructions.

But I'm getting a 403 Forbidden [IP: 80] when I run :

sudo apt-get install libopencv-dev

it return :

  The following NEW packages will be installed:
  gir1.2-gtk-2.0 libavcodec-dev libavformat-dev libavutil-dev libcv-dev
  libcvaux-dev libgtk2.0-dev libgtkglext1 libhighgui-dev libilmbase-dev
  libjasper-dev libjasper1 libopencv-calib3d-dev libopencv-calib3d2.4v5
  libopencv-contrib-dev libopencv-contrib2.4v5 libopencv-core-dev
  libopencv-core2.4v5 libopencv-dev libopencv-features2d-dev
  libopencv-features2d2.4v5 libopencv-flann-dev libopencv-flann2.4v5
  libopencv-gpu-dev libopencv-gpu2.4v5 libopencv-highgui-dev
  libopencv-highgui2.4v5 libopencv-imgproc-dev libopencv-imgproc2.4v5
  libopencv-legacy-dev libopencv-legacy2.4v5 libopencv-ml-dev
  libopencv-ml2.4v5 libopencv-nonfree2.4v5 libopencv-objdetect-dev
  libopencv-objdetect2.4v5 libopencv-ocl-dev libopencv-ocl2.4v5
  libopencv-photo-dev libopencv-photo2.4v5 libopencv-stitching-dev
  libopencv-stitching2.4v5 libopencv-superres-dev
  libopencv-superres2.4v5 libopencv-ts-dev libopencv-ts2.4v5
  libopencv-video-dev libopencv-video2.4v5 libopencv-videostab-dev
  libopencv-videostab2.4v5 libopencv2.4-java libopencv2.4-jni
  libopenexr-dev libpangox-1.0-0 libswresample-dev libswscale-dev
  libxml2-utils opencv-data
0 upgraded, 58 newly installed, 0 to remove and 0 not upgraded.
Need to get 7,286 kB/23.9 MB of archives.
After this operation, 122 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic/main amd64 libavutil-dev amd64 7:4.2.1-0york0~18.04.1
  403  Forbidden [IP: 80]
Err:2 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic/main amd64 libswresample-dev amd64 7:4.2.1-0york0~18.04.1
  403  Forbidden [IP: 80]
Err:3 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic/main amd64 libavcodec-dev amd64 7:4.2.1-0york0~18.04.1
  403  Forbidden [IP: 80]
Err:4 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic/main amd64 libavformat-dev amd64 7:4.2.1-0york0~18.04.1
  403  Forbidden [IP: 80]
Err:5 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic/main amd64 libswscale-dev amd64 7:4.2.1-0york0~18.04.1
  403  Forbidden [IP: 80]
E: Failed to fetch http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu/pool/main/f/ffmpeg/libavutil-dev_4.2.1-0york0~18.04.1_amd64.deb  403  Forbidden [IP: 80]
E: Failed to fetch

I tried to visit the links with a proxy, same error, they just seem to be broken.

Is there any alternative, or a way around this problem, thanks.

  • Thanks for your answer, do you mean the links worked for you, and if so, haw can I have access to those URLs. – local dev Dec 19 '19 at 9:01

The ppa:jonathonf/ffmpeg4 has been removed.

See https://launchpad.net/~jonathonf/+archive/ubuntu/ffmpeg-4

This PPA has been removed from public access as part of a protest against the abuse of open-source projects by large companies. For more detail visit the main page here: https://launchpad.net/~jonathonf

|improve this answer|||||
  • Thanks for the clarification, and I understand the author's complains, but what I'm I suppose to do now. is there any way around ? – local dev Dec 19 '19 at 9:16
  • You can ask the author. – Pilot6 Dec 19 '19 at 9:23
  • I'm gonna open an issue on the "shell scripts installation" git repo, I guess I'm not the only one concerned by this problem. Thanks again for your kindness. – local dev Dec 19 '19 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.