0

This is the first time I've tried to install a new OS with my current desktop. I created a bootable USB for Ubuntu 18.04 with Rufus (both with and without bad block checks) and attempted to boot into it through BIOS/Boot Manager, but received this error every time.

The only idea I have is that I tried to find the option to disable secure boot in the BIOS, but I couldn't find that option for my specific BIOS; I also made sure that the OS type was set to "Other OS" (other option was Windows 8). I've never run into issues booting into bootable USBs before though, and typically I don't need to disable secure boot to at least get to the installation.

The BIOS I have is a 2013 American Megatrends, I can provide other information if you ask (and if it's not trivial to find that information, please provide instruction).

EDIT: Tried again with a different USB stick, same errors. Tried to run the "check disc for errors" option within the Ubuntu boot menu, but then got the same error. Tried the same USB stick on my laptop and it worked fine, I was able to test Ubuntu and install (I didn't install, since I have no need on that computer).

Terminal output with errors

6
  • Looking at your screen picture it looks you failed to validate ISO or write to media (tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0 and help.ubuntu.com/community/Installation/CDIntegrityCheck); the second step can be performed on another box if you have issues with this one (if it fails on both boxes; ISO download or write to media was flawed; CD/disc refers to install media even if thumb-drive). The USB errors are signs of a failing/malfunctioning USB or hub (you can ignore; windows ignores those messages anyway); your issue looks like bad ISO or bad write. – guiverc Dec 18 '19 at 1:22
  • Thanks for the response! I tried the CD integrity check and got the same error. I also tried running the verification, but I'm running into issues just getting that set up (eg. I can't figure out how to download the checksum files in a location where the Ubuntu app on Windows 10 can actually see them?). I may just reformat the USB and pay careful attention to how I install the OS on there. – Rourke Sekelsky Dec 18 '19 at 1:56
  • If you get ANY errors in CD integrity check, the media is invalid. The only valid response from an integrity check is "No errors found"; which assuming you validated ISO before write to media; the write to your install media is the likely problem (the most common in my experience as a tester; I get at least 1 failed write a week). As for validating ISO, just use md5sum whateverISOiscalled.iso & compare - if's it's the same; assume it's valid (tutorials.ubuntu.com/tutorial/…) – guiverc Dec 18 '19 at 2:11
  • Hey, thanks for the extra information. I tried the same USB on my laptop and everything worked fine, so I think it's an error on my desktop's fault (just edited the main post a minute ago with that information). – Rourke Sekelsky Dec 18 '19 at 2:22
  • Yep, if the media passes on another device, I trust it too (blaming the box with the problem). As already stated I'd ignore the USB errors based on my prior experience (which may not apply to your unknown box), and next explore BIOS/UEFI settings for device. There are often two settings that need to be configured correctly (two settings must match but it's firmware specific). Some devices are just a PITA, esp. if you want to install alongside (erase & install can be easier). – guiverc Dec 18 '19 at 2:28
0

Finally fixed this issue, I started by just updating the BIOS to the latest version and I was then able to boot into the Ubuntu USB. It also had the option to enable/disable secure boot after updating, and it was disabled by default. Other than that I just had to enable the IOMMU controller in the BIOS to control the mouse & keyboard, and I was able to install Ubuntu onto my other drive successfully.

I still was getting some errors while booting into the USB drive (like "couldn't get size") but that's not a big deal for me, since those errors obviously go away once I'm done using the USB stick for installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.