0

This is on a dual boot system with Win7 and Ubuntu 19.10. It is a BIOS system.

After a Windows update last week I couldn't boot into Windows anymore. The boot halted with error 0xc0000428 for /Windows/system32/winload.exe "Windows cannot verify the digital signature for this file". I still could boot Windows in recovery mode, though.

After some research I booted Windows in repair mode, dropped to the command line and used bootrec /fixMBR. After doing that Windows 7 booted correctly, but Grub was gone.

Then I used a Rescatux USB stick to restore Grub. It worked but now Windows throws the same winload file signature error as in the beginning.

I'm stuck, please help.

0

I just encountered a similair problem on two(!) of my labtops (Dual booting with Win7 and Ubuntu 18 on Lenovo Thinkpad L450).

It occurred immediately after applying the "December 10, 2019—KB4530734 (Monthly Rollup)" - or actually during the intermediate reboot that Windows requires

I am positive that the root cause is the exact same thus it can be fixed like I did (I never got around to follow the "boot from a Win7 install media" tips google gave me :-)).

As I was having two identical systems I fixed it like this:

  1. On the still-working system: Made a copy of the file winload.exe to a USB stick
  2. On the BAD system: booted to Ubuntu
  3. Renamed the original (bad) winload.exe file (for potential further investigation)
  4. Added the "known good" winload.exe file
  5. Rebooted into Windows
  6. Now the Windows Update procedure continued (one more reboot IIRC) and I am able to boot into either system without a signature problem.

Now I updated my system #2 and encountered the error again, this time my USB disk was ready and the fix worked...!

I expect that you can use a copy of the winload.exe file from any still-booting Windows 7 system

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.