Just bought my new computer and already got big problems. This isn't a promising start.

After installing Ubuntu, I have problems with the Intel Wireless AC 9560 adapter. Made some research

> rfkill list all
0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: yes

> dmesg | grep -e wl -e iwl
[...] islwifi ... enabling device (0000 -> 0002)
[...] islwifi ... loaded firmware version 43.95eb4e97.0 op_mode iwlmvm
[...] islwifi ... Detected Intel(R) Dual Band Wireless AC 9560, REV=0x354
[...] islwifi ... Failed to load firmware chunk!
[...] islwifi ... ...
[...] islwifi ... ...
[...] islwifi ... Could not load the [0] uCode section
[...] islwifi ... Failed to start INIT ucode: -110
[...] islwifi ... ...

I downloaded the firmware iwlwifi-9000-pu-b0-jf-b0-33.ucode and put in the /lib/firmware and rebooted but nothing.

Have you got any idea on how to fix it? I don't have an ethernet at disposal, so I am offline and can download things from other computers and move it through a usb drive.

  • Does this answer your question? Not able turn on the wifi on Lenovo Y520 – Pilot6 Dec 17 '19 at 14:20
  • Just tried, but nothing changed – TakeMeToTheMoon Dec 17 '19 at 14:25
  • Is it still hard blocked? What is the Ubuntu version? – Pilot6 Dec 17 '19 at 14:25
  • 18.10. The computer is a lenovo yoga c640. I guess it is still hard blocked. That's weird, cuase now the "rfkill list all" does show only the Bluetooth (and that is not hardblocked anymore, so at least we solved another problem :D) – TakeMeToTheMoon Dec 17 '19 at 14:29
  • 1
    18.10 is EoL and not supported. Install a supported release and all should work. – Pilot6 Dec 17 '19 at 14:31

Have you tried newer kernel, like 5.2?

See https://bugzilla.kernel.org/show_bug.cgi?id=203891

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.