1

I have a Thinkpad X1 carbon 7th gen with an Intel 9560 wireless card. When I installed the Ubuntu 18.04 I noticed the wireless does not work.

My Wireless Situatio!

I've read some of the answers on other similar questions and ran some commands that were mentioned in those questions.

Here is the result of dmesg | grep iwl:

[3.845229] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[3.879509] iwlwifi 0000:00:14.3: loaded firmware version 43.95eb4e97.0 op_mode iwlmvm
[3.926980] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x354
[8.969971] iwlwifi 0000:00:14.3: Failed to load firmware chunk!
[8.969975] iwlwifi 0000:00:14.3: iwlwifi transaction failed, dumping registers
[8.969976] iwlwifi 0000:00:14.3: iwlwifi device config registers:
[8.970161] iwlwifi 0000:00:14.3: 00000000: 02f08086 00100406 02800000 00800000 ea238004 00000000 00000000 00000000
[8.970162] iwlwifi 0000:00:14.3: 00000020: 00000000 00000000 00000000 00308086 00000000 000000c8 00000000 000001ff
[8.970163] iwlwifi 0000:00:14.3: iwlwifi device memory mapped registers:
[8.970194] iwlwifi 0000:00:14.3: 00000000: 18489004 00000040 00000000 00000000 00000000 00000000 00000000 00000000
[8.970196] iwlwifi 0000:00:14.3: 00000020: 00000011 0c040005 00000351 d55555d5 d55555d5 d55555d5 80008040 001f0040
[8.970215] iwlwifi 0000:00:14.3: Could not load the [0] uCode section
[8.970219] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -110
[8.970220] iwlwifi 0000:00:14.3: Collecting data: trigger 15 fired.
[9.193626] iwlwifi 0000:00:14.3: Failing on timeout while stopping DMA channel 8 [0x0bad1122]
[9.206151] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -110

And here are the results of iwconfig:

enp0s31f6  no wireless extensions.

lo        no wireless extensions.

enxc025e9292f1d  no wireless extensions.

I also updated & upgraded all packages of my Linux.

How can I fix this issue? Any Ideas?

Thanks

3

I have the same situation as yours, down to the dmesg log level (iwlwifi INIT ), with my ThinkPad X1 Carbon Gen 7.

I found that the solution of Hrijul Bhatnagar works for me.

Prerequisite: either tether, or have a wired connection.

Run:

sudo apt update
sudo apt install git build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi/
make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
sudo modprobe iwlwifi

Reboot.

Hope it works for you too.

Edit: Hello @Shawn Dooley,

Before I attempted this solution, I have also:

Doing Hrijul Bhatnagar's solution was my fourth attempt.

|improve this answer|||||
  • 2
    I've done your exact prescription and It worked like a charm. :D Thanks a lot for your help. – Atorpat Dec 23 '19 at 18:42
  • 2
    Mate you saved my life here... copy pasting and after reboot.... OMG canot believe I sunk 4 hours into solution when yours was the only working one :O Thank you ! – Redrick Feb 18 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.