4

When I try to server with x2goclient, I get this error:

how can I fix it?

UPDATE: Both computers are on same local network with no firewalls, ssh connection between them works perfectly. Both computers are running Ubuntu 18.04, software versions: x2goserver 4.1.0.0-3 and x2goclient 4.1.1.1-2.

1

This is a non-backward compatible change in libssh, which broke one of the corner cases in SCP protocol (aka CVE-2019-14889). This is already fixed in the x2goclient (it was already fixed for windows clients before) and now it is just matter of time to get this into your favorite distribution (preferrably through bug report in their bug tracker https://bugs.launchpad.net/):

Also you can use a nightly builds repo https://launchpad.net/~x2go/+archive/ubuntu/ppa There is a fixed x2goclient with version 4.1.2.2-0~1884~ubuntu available and it`s working.

| improve this answer | |
  • thank you for your feedback dear friend! – stiv Dec 23 '19 at 14:29
0

I found a temporary dirty solution for this.

This seems to be an issue with the most recent updates of libssh which broke scp. Downgrading the libssh-4 package to its last version and restarting the x2goclient fixed it to me.

This can be done with apt, or synaptic:

search for libssh-4, click on it, Ctrl + E or package->Force version, and choose the earlier one

enter image description here

Keep in mind that holding old packages isn't recommended and this was a patch for some CVE, so might be all back to normal in future updates.

| improve this answer | |
  • which version exactly have you installed, I don't see any options under ctrl-e – stiv Dec 18 '19 at 3:29
  • I edited my reply with an image showing the version I choose. – mattf Dec 18 '19 at 4:41
  • cool, unfortunately this doesn't help in my case... screenshot doesn't match description, its libssh-grypt, not libssh – stiv Dec 18 '19 at 4:45
  • my bad... edited again. – mattf Dec 18 '19 at 5:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.