5

You can install less css compiler easy:

apt-get install lessc

But that only installs version 1.1.0. How can you update to the very latest version?

(The latest version is 1.3.0)

-- update --

  • I want to use the lessc command-line tool, not the client-side implentation.
9

Are you using it client-side (in the browser)? If so, it's a single JavaScript file, just download it.

If you're using it server-side (from a NodeJS application), or want the lessc command-line tool, the recommended way to install is using npm (the Node Package Manager):

npm install less

If you don't have npm, it's in the Ubuntu 11.10 repositories:

sudo apt-get install npm

or Using Software Center Install npm via the software center

  • 1
    I'm using the command line tool. Too bad it can't simply be installed via apt-get, but npm worked. I did get 2 warnings npm WARN publish-everything less@1.3.0 Adding entire directory to tarball. Please add a and npm WARN publish-everything less@1.3.0 .npmignore or specify a 'files' array in the package.json – Gerard Roche Apr 7 '12 at 10:17
  • npm is warning you that less doesn't specify which files to package up when installing the package. You might want to file a bug report with the developers, but it should be harmless. – Søren Løvborg Apr 7 '12 at 14:13
4

After a lot of head-hitting-desk moments I managed to solve this one.

Originally I had installed lessc using:

sudo apt-get install node-less yui-compressor

This gave me lessc 1.2.1 from the command lessc -v

Had to manually download the Quantal version from a repo http://www.ubuntuupdates.org/pm/node-less

(this gave me ~/Downloads/node-less_1.3.0~20120310-1_all.deb)

Then:

sudo dpkg -i ~/Downloads/node-less_1.3.0~20120310-1_all.deb

now I have lessc 1.3.0

and:

lessc twit-bootstrap_2.0/less/bootstrap.less > /var/tmp/bs.css

goes smoothly

1

That is because, it is the latest version available in repositories

http://packages.ubuntu.com/search?suite=all&section=all&arch=any&searchon=names&keywords=node-less

Whatever version is present in repositories you have added, apt-get will install only that version.

However if you want to install different version, you should try for other ways

1

As of Ubuntu 12.10, the node-less package installs v1.3.0 of lessc:

$ sudo apt-get install node-less
...
$ lessc -v
lessc 1.3.0 (LESS Compiler) [JavaScript]
1

Just :

npm install less -g

or with sudo

sudo npm install less -g

For checking version :

lessc -v
0

check your version :

node -v

you have to update nodejs first

sudo apt-get update
sudo apt-get install -y python-software-properties python g++ make
sudo add-apt-repository ppa:chris-lea/node.js
sudo apt-get update
sudo apt-get install nodejs

uninstall less / and istall again

 npm uninstall less
 npm install less

check version :

lessc -v

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.