1

I tried searching but with the terms I used I couldn't find anything similar.

I'm running Ubuntu server in multiple VMs on my Proxmox machine. I frequently run into this issue on my VMs and I don't understand enough to figure out why...

When I make new VMs I usually use the default Proxmox disk size of 32 GB which I figure will be PLENTY for running some small docker apps. I install Ubuntu Server with defaults but on LVM. Somehow my VMs keep filling up though. I even have a VM right now running 18.04 that can't update because the / partition is full and there isn't anything running on the server. I installed plex for some testing but it has no library or anything.

So when I do a DF it shows that the root is only 3.9GB. For some reason there are 3 other partitions that look like temp, swap or something. My DF is pasted below. Is there a setting I need to change during install to stop so much of my disk from being wasted?

udev                               7.9G     0  7.9G   0% /dev
tmpfs                              1.6G  9.0M  1.6G   1% /run
/dev/mapper/ubuntu--vg-ubuntu--lv  3.9G  3.9G     0 100% /
tmpfs                              7.9G  4.0K  7.9G   1% /dev/shm
tmpfs                              5.0M     0  5.0M   0% /run/lock
tmpfs                              7.9G     0  7.9G   0% /sys/fs/cgroup
/dev/loop0                          90M   90M     0 100% /snap/core/7713
/dev/loop1                          89M   89M     0 100% /snap/core/7396
/dev/vda2                          976M  222M  688M  25% /boot
tmpfs                              1.6G     0  1.6G   0% /run/user/1000

Adding parted output. Disk shows as 43GB here because I was going to expand it.

Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/ubuntu--vg-ubuntu--lv: 4295MB
Sector size (logical/physical): 512B/512B
Partition Table: loop
Disk Flags:

Number  Start  End     Size    File system  Flags
 1      0.00B  4295MB  4295MB  ext4


Model: Virtio Block Device (virtblk)
Disk /dev/vda: 42.9GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  2097kB  1049kB                     bios_grub
 2      2097kB  1076MB  1074MB  ext4
 3      1076MB  42.9GB  41.9GB
4
  • 2
    4 GB is way too little for / to run linux. Where are the rest of you 32 GB? Please update your question with the ouput of sudo parted -l. – Soren A Dec 16 '19 at 20:32
  • I'm well aware it's too little. I'm trying to figure out why this happens, what I need to do differently during install to avoid this. You can see the storage in the df output I listed. The rest is going to /dev /dev/shm and /sys/fs/cgroup. – Sqwrly Dec 16 '19 at 21:01
  • Please add the information I asked. tmpfs is temporary filesystems that resides in memory, not on disk. When you are at it also check the LVM layout. – Soren A Dec 16 '19 at 21:10
  • I find that hard to believe when all of those partitions listed add up to 32GB but I'm not qualified to say that. Adding the info to the main post since it doesn't fit here. – Sqwrly Dec 16 '19 at 21:23
0

I think I found my own answer. It seems that even though I selected "Use An Entire Disk And Setup LVM" it didn't use the entire disk. It set 4G to the root partition and leaves the rest as unused. Seems like a strange default when I tell it to use the entire disk.

I couldn't copy and paste the text since this is through Proxmox VNC in a browser.

https://i.imgur.com/RE3V71U.jpg

1
  • So what did you do to get it to use the entire disk space? Facing a similar issue now and only just noticed when MongoDB died and won't start back up again :(. Think it'll just be easier to nuke the VM but want to make sure I set it up properly this time. – KillerKode Jun 30 '20 at 21:01
-1

The answer is that the remainder of your virtual disk is allocated to LVM, but the volume group has empty unused space not allocated to filesystems. You need to either extend the root logical volume (lvextend -r -l +100%FREE ubuntu-vg/ubuntu-lv) or create file systems to mount underneath / (/var, /home, etc.) with lvcreate.

2
  • I was looking for the reason it does it on install. That said I tried the lvextend command you listed and it says 'write error failed: No space left on device' – Sqwrly Dec 16 '19 at 23:29
  • OK, that implies that there are unmounted logical volumes sitting out there. What's the output of vgs and lvs? – Jim Trigg Dec 18 '19 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.