2

I've installed another desktop environment which I would like to try. I am not sure how to switch to it.

Is there still a button on the log in screen that will switch desktop environments? This same question for previous versions of ubuntu yields screenshots of this button. But I cannot find any button on the log in screen that does this.

So, in ubuntu 19.10, does there exist a button to switch desktop environments? If so, where is it? If not, what is an alternative method to switch desktop environments after I've already installed one?

██████@████-linux:~$ ls /usr/share/xsessions
gnome-flashback-compiz.desktop    ubuntu.desktop
gnome-flashback-metacity.desktop

The gear icon does not show up for me, as the answers indicate it should.

Solved. I was not logged out properly. I locked the screen thinking that was logging out. Logging out properly fixed the issue.

  • Which " another desktop environment " were installed? How did you installed it? – N0rbert Dec 15 '19 at 10:51
  • gnome flashback metacity, as shown in the output of ls /usr/share/xsessions. It was installed through the package manager, as normal. Of course this shouldn't matter for answering the question. – jrkirby Dec 15 '19 at 10:54
  • 1
    Yes there is a gear type log (how this appears will depend on what DM you are using, ie. gdm3, sddm, lightdm etc) where you click on it, and you'll be offered a list of what's available. If a DE doesn't show, it usually means it's not fully installed (ie. all packages required weren't installed). You select the DE when you login (ie. username/password entry screen). – guiverc Dec 15 '19 at 10:59
  • You are obviously not logged out. You are at the lock screen, but your session is still active. You need to be logged out, i.e., terminate your session before the cog will be available. See the bottom of my answer for your specific case. – vanadium Dec 15 '19 at 12:02
  • This was the case. Thanks vanadium :) – jrkirby Dec 15 '19 at 12:07
1

Ubuntu 19.10 uses GDM3 as login manager. Also this login manager allows you to login to a different session ("desktop environment") during login.

  • Make sure you selected your user on the login screen such that your password is displayed.
  • Before entering the password, click the "cog" icon to select a session.

enter image description here

(Screen for Ubuntu 18.04 but similar in 19.10) The session you selected will stay in effect during subsequent logins until you choose another session.

For your particular case: your screenshot shows you are currently logged in. What you are showing is a lock screen. Your session is still active, but the lock screen protects your account so other people could not get access while you are away from the computer without having logged out. By default, it will kick in when the screen is blanked after a certain time of inactivity (configurable on Settings - Power). In Ubuntu, you can also lock the computer yourself with the hotkey Super+l). Thus

  • Enter your password to return to your current session
  • In the top right corner on the top bar, click the status menu button
  • In the menu, click the entry showing your name. Then click "log out".

Now, you will have effectively logged out of your session. You will now have a cog to select another session for logging in.

1

You have to logout from your current session or reboot and then:

  • if you are using GDM3 - select your login name and then click on gear gear button and select needed session:

    GDM3

  • if you are using LighDM - click on circle circle button and select needed session:

    LightDM


Notes:

  1. GNOME FlashBack is usually installed by sudo apt-get install gnome-session-flashback
  2. One can switch between GDM3 and LightDM using sudo dpkg-reconfigure gdm3 or sudo dpkg-reconfigure lightdm (install it first with sudo apt-get install lightdm if not installed)
  • The gear icon does not appear for me. Someone else mentioned that it might not appear if I did not properly install the other desktop environment. I used sudo apt-get install gnome-session-flashback to install it. Is there any other tool to verify that I installed it properly other than ls /usr/share/xsessions, which appears to indicate a correct installation? Is there any other reason why the gear might not appear? – jrkirby Dec 15 '19 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.