1

When redshift is running - screen dims a bit. This was noticeable while watching videos in VLC. Even if I "disable" redshift from its options the dimming remains. Only when I exit the program brightness returns to normal.

Day & night brightness values are also set as 1.0 in config so no issue there. There is no option related to dimming.

Not sure what is the problem or how can it be fixed.

Here is the redshift config:

; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=5500
temp-night=3800

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature.
transition=1

; Set the screen brightness. Default is 1.0.
brightness=1.0
; It is also possible to use different settings for day and night
; since version 1.8.
brightness-day=1.0
brightness-night=1.0
; Set the screen gamma (for all colors, or each color channel
; individually)
; gamma=0.8
 gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: 'geoclue', 'geoclue2', 'manual'
; type 'redshift -l list' to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: 'randr', 'vidmode'
; type 'redshift -m list' to see all possible values.
; 'randr' is the preferred method, 'vidmode' is an older API.
; but works in some cases when 'randr' does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type 'redshift -l PROVIDER:help' to see the settings.
; ex: 'redshift -l manual:help'
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=28.459497
lon=77.026634

; Configuration of the adjustment-method
; type 'redshift -m METHOD:help' to see the settings.
; ex: 'redshift -m randr:help'
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the
; second screen. If this option is not specified, Redshift will try
; to adjust _all_ screens.
[randr]
4
  • 1
    Does this answer your question? Can't disable redshift Dec 15, 2019 at 5:28
  • 2
    I would check your redshift.conf file, it allows configuration of both daylight & sunlight (many options) and if you've set daylight to be less than full - it's only when you exit the program that you notice the untouched colors of redshift (ie. what you're describing). Check your configuration (daylight doesn't mean no change!)
    – guiverc
    Dec 15, 2019 at 6:12
  • @guiverc added the conf file, please have a look Feb 25, 2020 at 13:22
  • @WinEunuuchs2Unix - no it doesn't Feb 25, 2020 at 16:55

1 Answer 1

0

Add this to the ~/.config/redshift.conf

If the file isn't there:

cd ~/.config/
touch redshift.conf

Add these:

[redshift]
gamma=0.9

A lower gamma means a dimmer screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.