13

I'm using Ubuntu 18.04 with nemo as the file manager, and out of nowhere I can no longer mount disks or partitions which show up just by double-clicking them, when just a few weeks ago this worked perfectly fine! Any idea what changed? Perhaps an update messed it up?

The error is:

Unable to mount NAME_OF_DISK. Not authorized to perform operation.

Screenshot from nemo file manager:

enter image description here

This answer doesn't seem to help me either, as I just booted up and have nothing open really. Repeated reboots don't solve the problem. How would I find out which application might be holding the lock? Mount Flashdrive: Not Authorized to perform operation.

Note that the work-around is to manually do it with sudo, but I really don't like having to use sudo! Ex:

sudo mkdir /media/mydisk
sudo mount /dev/sdb1 /media/mydisk

Or this works too:

sudo gnome-disks

Then use the gnome "Disks" utility to mount via the GUI.

If I do this though I cannot view the mounted partition unless I also run my file manager as root. Ex:

sudo nemo

Then navigate around in a GUI file manage window with elevated permissions.


Update:

Related

  1. https://superuser.com/questions/1151993/usb-automount-fail-not-authorized--related to Polkit and plugdev group?
2
  • Not sure why I got a downvote. This problem cost me 4 hrs of valuable time, and I carefully documented the problem, and then the solution too once I found it. Just trying to help others. Dec 15, 2019 at 7:11
  • 1
    A rogue downvoter at Ask Ubuntu has been downvoting new posts for about an hour.
    – karel
    Dec 15, 2019 at 8:02

2 Answers 2

30

(Chrome Remote Desktop seems to be a problem for a lot of things! It will also block you from being an admin to operate your own printer!)

Solved. For my particular case the problem was Chrome Remote Desktop. Uninstalling it solved it.

sudo apt autoremove chrome-remote-desktop 

Source for the uninstall command was JVApen here.

I've had many problems with Chrome Remote Desktop on Ubuntu, so I'm not really sure what to do about it. For now I suppose I'll leave it uninstalled and try using NoMachine instead, although that requires messing with your router settings and opening up port-forwarding from the outside internet to your internal local area network, which Chrome Remote Desktop seems to avoid by (I'm guessing) instead using a reverse tunnel through an outgoing connection from your house out to a Google server. In other words, the Google approach is probably safer, and is certainly much more convenient, if only it worked. [UPDATE: I'm sticking with NoMachine. Here are some configuration settings I wrote down that you may find useful.]

Note that I originally installed Chrome Remote Desktop using these instructions here:

  1. https://medium.com/@vsimon/how-to-install-chrome-remote-desktop-on-ubuntu-18-04-52d99980d83e and here:
  2. https://superuser.com/questions/778028/configuring-chrome-remote-desktop-with-ubuntu-gnome-14-04/850359#850359.

I then had this problem here:

  1. Can't connect to Chrome Remote Desktop on Ubuntu 18.

I've also had problems with Chrome Remote Desktop taking over audio, and making my audio not play back, and other things like that. Google's support for it on Linux is somewhat poor, and I'm continually fighting with it it turns out.

Related:

  1. Mount Flashdrive: Not Authorized to perform operation
  2. https://medium.com/@vsimon/how-to-install-chrome-remote-desktop-on-ubuntu-18-04-52d99980d83e
  3. https://superuser.com/questions/778028/configuring-chrome-remote-desktop-with-ubuntu-gnome-14-04/850359#850359
  4. "Some required components are missing"--cannot connect from Linux to Windows w/Chrome Remote Desktop
8
  • 1
    thanks ~! you saved my day~! I have been stuck here for days~! none of other solutions worked for me. Really thank you. I think we'd better to let Google know this. this is really bad.
    – Franva
    Dec 20, 2019 at 23:13
  • Hey thanks; be sure to upvote both the question and answer then if it was that helpful, and I recommend you open up a bug report with Google and post a link to your bug report as a comment here. Dec 21, 2019 at 0:58
  • 1
    Please open up a bug report in Google Support, they need to know about this. Mar 6, 2020 at 7:51
  • 1
    @user68186, link is now fixed in the answer. Feb 2 at 15:23
  • 1
    May I suggest you ask and answer the question "How to setup nomachine?" and answer the question with the text you have put up in the github. This will help the Ask Ubuntu community.
    – user68186
    Feb 2 at 15:29
0

Another suggestion to improve answer (my rep is too low to comment on ubuntu also I am using debian so please verify as it should be relevant to ubuntu, but not sure if the commands need to be translated). You need permissions to start/stop services either as root/sudo or another permission group specific to process & systemctl. Status should work without root/sudo permissions.

To see if the chrome-remote-desktop is running

sudo systemctl status chrome-remote-desktop@user

If so, it will show [Active: active (running) since ... ]

sudo systemctl stop chrome-remote-desktop@user

Desktop - usb should mount automatically, you can select to mount, or use the command line to mnt assuming you have the permissions to mount as well.

When done

sudo systemctl stop chrome-remote-desktop@user
start chrome-remote-desktop@user

Then check to be sure all is running and well

sudo systemctl status chrome-remote-desktop@user

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.