1

Don't know what happened. But all of sudden I can't push updates in GitHub. A month ago I used SSH keys to integrate VS Code with Github so that I do not have to type email & password every single time when I use to push updates to the Git repository.

I think BleachBit has deleted some important files and this is happening. But this is my wild guess. I can't confirm this. Because I didn't do anything other than that. VS Code used to work fine. Suddenly this is happening. I gotta be careful with Bleachbit if this is an act of Bleachbit. Screenshot of the error message.

Meanwhile, I am going nuts over for a week thinking how to solve this issue. If you had this issue, then do comment it out.

When I did ls /usr/bin/ssh-askpass, it say there is no file or folder. This might be the cause of the problem. But I do see these folders inside /usr/bin related to ssh: ssh ssh-add //is a file that supposed to be deleted when I unistalled ssh-askpass ssh-agent //is a file ssh-argv0 ssh-copy-id ssh-keygen ssh-keyscan

  • Can you confirm that the file ssh-askpass is there or not? – schrodigerscatcuriosity Dec 14 '19 at 16:59
  • @guillermochamorro How can I confirm this? I do see same three files inside .ssh in home folder: id_rsa, id_rsa.pub and known_hosts. – Pranav Dec 14 '19 at 17:47
  • Try ls /usr/bin/ssh-askpass – schrodigerscatcuriosity Dec 14 '19 at 17:49
  • @guillermochamorro It says no such file or directory. – Pranav Dec 14 '19 at 17:55
4

I had to do 2 things to get this solved.

  1. As @Wan-Chap said above

     sudo apt install ssh-askpass
    
  2. Use this command to add bitbucket.org (In my case it was Bitbucket)

     ssh-keyscan -t rsa bitbucket.org >> ~/.ssh/known_hosts
    
| improve this answer | |
  • instead of ">" you should use ">>" to append otherwise it will overwrite existing known hosts, which might not be a desirable outcome... – efaruk Jul 20 at 0:48
  • @efaruk Thanks for mentioning. I have updated. – antonD Jul 20 at 8:17
3

Well, I think (& am 100%) I found my solution. If you use services like SSH keys, make sure you don't disable SSH Key Agent. It was a stupid mistake. A week ago, I tried to decrease my boot time by disabling all unwanted services that launch itself while booting. I read askubuntu post asked by someone to disable those services. Now I have realized it.

Screenshot

Lesson learned. Don't do anything which you know don't for sure. Try not to disable other startup services related to SSH if you depend on it. After enabling the service, you might have to reboot. Then you are good to go.

| improve this answer | |
1

It seems your ssh-askpass is missing. Just re-install it by:

sudo apt install ssh-askpass
| improve this answer | |
  • I already tried this solution. This is not a standard mechanism to solve this problem. The whole idea of having SSH keys is to make VS code push updates without having to enter a password like 1000 times. This does solve the problem but it will ask password in each push to git repo. – Pranav Dec 16 '19 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.