5

I'm using Kubuntu 19.10 and I have a problem with xdg-open.

Every link that redirects to an application doesn't work. For example slack links: I am on their website, when the link of accessing a workspace appear I only get the popup: "Open xdg-open?" and then nothing happens.

Same thing for zoom video calls. I click the link that should redirect me from the browser to the zoom application, same pop-up and nothing happens.

How can I fix it? The only thing that looks correct is the browser, so if I run in my terminal: xdg-open www.google.com it opens the window on my default browser

  • Also consider asking at reddit.com/r/kde or reddit.com/r/Kubuntu. – DK Bose Dec 14 '19 at 13:28
  • 1
    Does this answer your question? How to set which application is launched by xdg-open? – Tejas Lotlikar Dec 14 '19 at 16:34
  • 1
    Not really, I have no problem with the browser settings I need to configure other programs (like Slack and Zoom) and I'm not sure how to do that – ste Dec 16 '19 at 19:37
  • Are you using Chromium? I have the same problem and I think it's related to a recent (forced) switch to using the Snap version of Chromium. If I copy and paste the app.slack.com/ssb/add?s=1&v=4.2.0 url into Firefox and sign in, then the xdg-open bit succeeds. – EoghanM Jan 29 at 9:22
  • Having the same issue with LXDE + 20.04. Many programs affected also like Slack, Discord, and Zoom. If I run xdg-open URL manually in a terminal I simply get an error message with my home/user prepended to the URL path (so it obviously fails) – Daniel Rosehill Apr 22 at 12:06
1

I had the same problem. I run Debian Buster
Stevel's answer here on the Linux stack exchange helped me solve it.

To elaborate on how to apply the fix.

  1. Open up the the xdg-open file as a superuser so you can edit and save the file.
    You should find the file at usr/bin/xdr-open
    Alternatively run the command which xdg-open in your terminal to find the path to the xdg-open file
  2. Find the line that reads if pcmanfm --help >/dev/null 2>&1 -a is_file_url_or_path "$1"; then using Ctrl+F or however you want.
  3. Edit the -a on that line to &&
    Your edited line should read if pcmanfm --help >/dev/null 2>&1 && is_file_url_or_path "$1"; then
  4. Save and test.

Good luck!

| improve this answer | |
  • I change the file accordingly but it didn't change anything :( – ste Jan 14 at 13:32
  • This line should only be evaluated in case your desktop environment is LXDE (e.g. default in Lubuntu), not KDE (default on Kubuntu). – T. Verron Mar 31 at 15:31
  • 1
    My line was already the correct one. So, still have the problem that can't open Zoom - at final step get stuck saying "Open xdg-open". And, when I click this option nothing happens. Hmmmmm – Duncan Jun 22 at 11:27
  • Same - my line was already correct, but nothing happens with xdg-open. Can't open Zoom or similar. Same result in both Chrome and Firefox. Only since upgrading from Linux Mint 19 to 20. – qwa Sep 15 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.