I am trying to install blender 2.8 from here. I've run:

sudo add-apt-repository ppa:thomas-schiex/blender
sudo apt-get update

However, when I run apt search blender, it still shows me the version 2.79 version from the official bionic-updates repo.

I would try and specify the exact repo, but this ppa names the release as bionic main, i.e. super generic terms that overlap with the official names.

I've tried removing the sources.list file so that only the blender package in the ppa repo would get found, but that doesn't work either (Blender is simply not found at all). It seems as though the ppa is not seen by my system.

Edit: Result of apt-cache policy blender:

  Installed: (none)
  Candidate: 2.79.b+dfsg0-1ubuntu1.18.04.1
  Version table:
     2.79.b+dfsg0-1ubuntu1.18.04.1 500
        500 http://ports.ubuntu.com/ubuntu-ports bionic-updates/universe arm64 Packages
     2.79.b+dfsg0-1 500
        500 http://ports.ubuntu.com/ubuntu-ports bionic/universe arm64 Packages

Edit2: Running sudo apt update confirms that we're hitting the ppa:

Hit:9 http://international.download.nvidia.com/jetson/repos/common r32 InRelease
Hit:10 http://international.download.nvidia.com/jetson/repos/t210 r32 InRelease
Hit:12 http://ppa.launchpad.net/thomas-schiex/blender/ubuntu bionic InRelease
Hit:13 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Hit:14 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease
Hit:15 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease
Hit:17 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.

... but it's still showing only version 2.79 as an option.

  • 1
    please edit and add the output of apt-cache policy blender
    – cmak.fr
    Dec 14, 2019 at 8:19
  • sudo apt install blender will install the ppa version. So what's the actual question here? ( maybe why doesn't apt search find this ppa's package??
    – doug
    Dec 14, 2019 at 15:18
  • @doug sudo apt install blender does not in my case. It installs the 2.79 version from ubuntu's bionic-updates/universe. When I comment out those repos in source.list, my system detects no blender whatsoever. Seems like it's just not seeing the ppa
    – Magnus
    Dec 14, 2019 at 15:29
  • It looks like you didn't add the repository properly. Please post the output of sudo apt update command to your question.
    – Pilot6
    Dec 14, 2019 at 15:34
  • 1
    I am puzzled. You've added the repo OK.
    – Pilot6
    Dec 14, 2019 at 15:48

2 Answers 2


Your architecture seems to be arm64.

There are no arm64 (only amd64) packages in that PPA.

If you need blender version from that PPA, you'll have to build it yourself from source.


Magnus, there is likely an issue in your setup. Please check that when you do "apt update", it lists the PPA. You should see a line containing the following text:

http://ppa.launchpad.net/thomas-schiex/blender/ubuntu bionic InRelease

If you don't see it, then the PPA is not a source for you. There may be other issues, but this one is the most likely.

BTW, because the PPA is updated more frequently than versions of blender, the blender version numbering is based on the git commit number and hash. This is always increasing. It should (and has for several years) make update easy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.