1

I followed the instructions in https://askubuntu.com/a/1029905/340383 using this configuration:

Hide Top Bar settings

Which seems to be correct, but the Top Bar is still showing on the right monitor (I have a left and right monitor):

enter image description here

Is there a switch or setting that I need to change to make this work the way I think it should?

I do have the chrome-gnome-shell installed via https://addons.mozilla.org/en-US/firefox/addon/gnome-shell-integration/

as indicated by:

$ sudo apt install chrome-gnome-shell
Reading package lists... Done
Building dependency tree       
Reading state information... Done
chrome-gnome-shell is already the newest version (10.1-5).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$ dpkg --list chrome-gnome-shell
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name               Version      Architecture Description
+++-==================-============-============-===================================================
ii  chrome-gnome-shell 10.1-5       all          GNOME Shell extensions integration for web browsers
$ 

Update 1

Here is a screenshot of the Settings/Devices/Displays window showing two NEC 24" monitors. The Top Bar is showing only on the right monitor (the one identified as "1", likely because I used the drag/drop inside that window to move "1" to the right, but not sure that is the root cause of this problem). enter image description here

Update 2

In response to @pomsky's question, we have this output:

$ gsettings get org.gnome.shell enabled-extensions
['hide-top-panel@dimka665.gmail.com', 'alternate-tab@gnome-shell-extensions.gcampax.github.com', 'show-desktop@l300lvl.tk', 'show-desktop-button@amivaleo', 'hidetopbar@mathieu.bidon.ca']
$ ls ~/.local/share/gnome-shell/extensions/ 
alternate-tab@gnome-shell-extensions.gcampax.github.com  hidetopbar@mathieu.bidon.ca  show-desktop-button@amivaleo
$ 

Update 3

In response to @vanadium's comment, I opened up Gnome Tweaks, and started to do that test, but then got distracted by the icon highlighted with the red ellipse below, and then to the right of it saw that the Hide top bar extension seemed to be disabled.

Hovering the mouse over the icon in the red ellipse just shows "Error loading extension", which is pretty vague.

Gnome Tweaks Prior to changes

Update 4

Clicking on one or two of the items inside the Gnome-Tweaks/Extensions view shown above popped up a note about needing to restart Gnome. Why didn't it prompt me for that somewhere when I installed the extension? Or did it and I just didn't see it?:

Gnome Tweaks click Extension showing restart message

Update 5

After a reboot, now the Top Bar is successfully unmapping itself until which time I move the cursor up to the top edge of the right-most monitor where it then shows itself.

Update 6

Prior to uninstalling anything as suggested by vanadiums answer, here is a FireFox page screenshot of what I see from https://extensions.gnome.org/local/

enter image description here

This seems to correlate with this command-line result:

$ cd /usr/share/gnome-shell/extensions/
$ ls -1
desktop-icons@csoriano
system76-power@system76.com
ubuntu-appindicators@ubuntu.com
ubuntu-dock@ubuntu.com
$ cd ~/.local/share/gnome-shell/extensions/
$ ls -1
alternate-tab@gnome-shell-extensions.gcampax.github.com
hidetopbar@mathieu.bidon.ca
show-desktop-button@amivaleo
$ 

I suspect the ones under ~/.local/share/gnome-shell/extensions/ came about via the GNOME Shell integration Firefox extension

Update 7

I uninstalled all of the ones I could uninstall, that had X icons to the right of them inside https://extensions.gnome.org/local/ and looked inside Ubuntu Software Center, "Installed" tab (as referenced by https://askubuntu.com/a/1171225/340383), and saw them removed at the very bottom. But then installed just one like this from the command-line:

$ sudo apt install gnome-shell-extension-autohidetopbar
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  gnome-shell-extension-autohidetopbar
0 upgraded, 1 newly installed, 0 to remove and 10 not upgraded.
Need to get 16.3 kB of archives.
After this operation, 91.1 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu eoan/universe amd64 gnome-shell-extension-autohidetopbar all 20180908-2 [16.3 kB]
Fetched 16.3 kB in 0s (64.0 kB/s)
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline

Selecting previously unselected package gnome-shell-extension-autohidetopbar.
(Reading database ... 404735 files and directories currently installed.)
Preparing to unpack .../gnome-shell-extension-autohidetopbar_20180908-2_all.deb ...
Progress: [  0%] [..........................................................................................................................................................................................] Progress: [ 20%] [#####################################.....................................................................................................................................................] Unpacking gnome-shell-extension-autohidetopbar (20180908-2) ...
Progress: [ 40%] [##########################################################################................................................................................................................] Setting up gnome-shell-extension-autohidetopbar (20180908-2) ...
Progress: [ 60%] [###############################################################################################################...........................................................................] Progress: [ 80%] [####################################################################################################################################################......................................]

Verified that I had it installed:

$ dpkg --list gnome-shell-extension-\*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                     Version                            Architecture Description
+++-========================================-==================================-============-========================================================
ii  gnome-shell-extension-appindicator       30-1                               all          AppIndicator/KStatusNotifierItem support for GNOME Shell
ii  gnome-shell-extension-autohidetopbar     20180908-2                         all          GNOME shell automatic topbar hider
un  gnome-shell-extension-caffeine           <none>                             <none>       (no description available)
un  gnome-shell-extension-dash-to-panel      <none>                             <none>       (no description available)
un  gnome-shell-extension-dashtodock         <none>                             <none>       (no description available)
ii  gnome-shell-extension-desktop-icons      19.10.2-1                          all          desktop icon support for GNOME Shell
un  gnome-shell-extension-multi-monitors     <none>                             <none>       (no description available)
un  gnome-shell-extension-pixelsaver         <none>                             <none>       (no description available)
ii  gnome-shell-extension-system76-power     1.2.0~1571861523~19.10~f9f05fb~dev all          Gnome-shell extension for System76 Power Management
un  gnome-shell-extension-taskbar            <none>                             <none>       (no description available)
un  gnome-shell-extension-top-icons-plus     <none>                             <none>       (no description available)
ii  gnome-shell-extension-ubuntu-dock        67ubuntu19.10.1                    all          Ubuntu Dock for GNOME Shell
un  gnome-shell-extension-workspaces-to-dock <none>                             <none>       (no description available)
$ date
Sun 15 Dec 2019 10:05:41 AM PST

But then the Ubuntu Software Center's "Installed" tab did not change (it did change immediately when I uninstalled the package from https://extensions.gnome.org/local/)

The behavior of automatic hiding did not change at all. It is not working at this point. So I suspected this is still the same bug whereby a reboot or GNOME shell restart is required, but they are not sending me a message stating such is required. But in this case, that stands to reason no such message is given, since I used apt install from the command-line which never has, at least for me for many years, notified me of required reboots.

I rebooted, and now the autohiding of the Top Bar is there.

What is most concerning is that the Ubuntu Software Center's "Installed" tab still does not show it, even though I've installed it via apt install, but that is a separate issue.

  • "the Top Bar is still showing on the right monitor" so it worked on the left monitor? – pomsky Dec 13 '19 at 15:35
  • The Top Bar is not showing on the left monitor at all. Let me paste in a screenshot of the Devices/Displays window into the OP. – bgoodr Dec 13 '19 at 15:58
  • Now pasted the Displays view from Settings into the OP as Update 1. – bgoodr Dec 13 '19 at 16:02
  • 1
    Issue with multi-monitor support of Gnome Shell and/or the extension, likely. Perhaps try to switch to "Workspaces span displays" setting in Gnome Tweaks, but then switching workspaces will also change the second monitor (that then becomes an extension of the same workspace). – vanadium Dec 13 '19 at 16:59
  • 1
    Please provide the outputs of the following two commands: gsettings get org.gnome.shell enabled-extensions and ls ~/.local/share/gnome-shell/extensions/ – pomsky Dec 13 '19 at 18:21
1

That the extension has issues may be caused by a mismatch between your version and that of the Gnome Shell version your Ubuntu Desktop is running. You are much less likely to run into issues if you install, to the maximum extent, extensions that are available in the Ubuntu repositories.

The advice, therefore, is to

  1. Remove the extension you installed from the Gnome Shell extensions website

  2. Install the officially packaged version using either Ubuntu Software, Synaptic package manager or with the command sudo apt install gnome-shell-extension-autohidetopbar

Still, this may not cause your top bar to disappear on multiple monitors. Your issues with having this working on multiple monitors reflects general issues with multi-monitor support by Gnome Shell that only can be adequately addressed by the Gnome Shell developers.

  • +1 for your helpful answer both here and in the comments on both of my related posts (the other one at askubuntu.com/questions/1195919/…). I think that might be the right answer but now I have to ensure that all of the extensions I've installed can be replaced with corresponding Ubuntu packages via sudo apt install gnome-shell-extension-SOMETHING type commands. I will try that and write back. – bgoodr Dec 15 '19 at 15:20
  • Added Update 6 to the OP as a record of what I see prior to uninstalling anything, which is called for by this answer. – bgoodr Dec 15 '19 at 17:53
  • Not sure what this can add. Does the hide top bar extension work now? This is what you asked in the first place. – vanadium Dec 15 '19 at 17:58
  • I added Update 7 to explain that it did not work immediately but only after yet another reboot. I do not understand the requirement of rebooting or GNOME Shell restarts. That is at the root of the problem which is not clearly documenting that installation of GNOME shell extensions always requires restarting something. Or even that a restart/reboot is even required. I don't have to do that for most Firefox extensions, and this should be the same for GNOME too. – bgoodr Dec 15 '19 at 18:28
0

(Note: This may or may not be the root cause of this. See vanadiums answer for a possibly superior answer for installing the Ubuntu packages, but it is still requiring reboots, as shown in Update 7 in the original post)

You have to reboot your host or somehow restart GNOME after installing the Hide Top Bar GNOME extension.

I believe this is either a case whereby that is a requirement, and I just did not notice it, or the requirement was not communicated properly to the user (or was, but was done via notification that quickly disappeared so was not known).

See Update 5 in the OP, and the screenshot in Update 4 where I discovered it. And see Update 7 showing that rebooting or restarting-GNOME-shell is still required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.