5

Every time I connect an external disk with an encrypted partition a fullscreen pop up dialog appears:

Enter a passphrase to unlock the volume

I usually do not want to decrypt this partition so the message is disrupting.

I am using Ubuntu 19.04 and GNOME Shell 3.32.1.

In Settings > Devices > Removable Media I have "Never prompt to start programs on media insertion" checked, but the pop up still appears.

How can I prevent these dialogs?


Edit: An answer below explains how to disable automount altogether. This is an improvement, though I would ideally like to enable automount and not decrypt encrypted volumes by default.

  • Perhaps you can clarify a bit. You have to decrypt it before you can use it. If you don't plan on using it why would you plug it in? – WinEunuuchs2Unix Dec 21 '19 at 19:38
  • It is a disk with multiple volumes. Only one on encrypted. – Ian Mackinnon Dec 21 '19 at 19:40
  • Got it, so the real question could be "how to only auto-mount unencrypted partitions"? – WinEunuuchs2Unix Dec 21 '19 at 19:54
3
+50

I got this working in Ubuntu 18.04, so hopefully this will translate to 19.04:

Run dconf-editor and search for automount. You will see (2) settings, both under /org/gnome/desktop/media-handling: automount and automount-open. Switch automount to off.

If you need to mount these devices, you can always go into Disks and mount them from there.

|improve this answer|||||
  • Thanks. I used the command line version gsettings set org.gnome.desktop.media-handling automount false and it does just what it says :) – Ian Mackinnon Dec 20 '19 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.