2

I’m new to Ubuntu and in Windows I used to have AutoHotkey constantly running so I could input letters with tildes (á, é, ñ, etc.) with certain commands Ctrl+Alt+letter. Apparently AutoHotkey is not available for Ubuntu so I tried using AutoKey but it kept freezing and it mostly didn’t work. Now I tried making custom desktop shortcuts with the keyboard configurations but they don’t work and I don’t know why. When I press the keys the word is not written. Does anyone have any suggestion?

screenshot of the shortcuts screenshot of one of the shortcuts

EDIT: I added the pictures so you can see the shortcuts. Whenever I press those keys the cursor blinks as if a letter is being written but no actual letter is.

  • I think the problem is with the command, I'm supposed to write some kind of command to write the unicode character, but I don't know how to do this. – Kirtpole Dec 12 '19 at 21:42
1

I solved it! Apparently what you need to do is download xdotool and then add the following command:

bash -c 'sleep 0.3 && xdotool key U00e1'

This executes a bash command that waits 0.3 seconds and then inputs the key U00e1 in Unicode (in this case this is á). You can change the sleep time and the Unicode symbol you want to enter.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.