0

I have been a Linux user for a number of years, and about a year on this very system I'm reporting for. It was running xubuntu perfectly up to about a week ago. I have automatic updates on it, and I believe it was after an update. Mouse just randomly stops working for a few seconds, you cannot move it nor click it. This can happen in succession for a number of times. It is so annoying, I would have reinstalled the whole thing if I did not have important work on it. I have verified it with a different mouse, and also tried Windows 10 that I have on dual boot. Windows does not have any problems.

It is the latest kernel on Ryzen 3 and GeForce 1070ti with proprietary drivers. Any help would be appreciated.

  • Is it a wireless mouse? – kenn Dec 12 '19 at 16:17
  • no, wired. i have tried two of them, same problem. o, and it happens more if i plug it into the computer directly. i usually plug it into the keyboard usb extension. i have one of those old microsoft keyboards that have two usb plugs on them, so i use that for convenience. – Nele Dec 12 '19 at 16:21
  • check out this askubuntu.com/questions/80638/… – kenn Dec 12 '19 at 16:30
  • none of the usb autosuspend suggestions worked... – Nele Dec 12 '19 at 16:56
1

This seem to be a problem when GeForce graphics cards are present on an AMD machine. I looked into the kernel log, and there was a constant error

reset low-speed USB device number 21 using xhci_hcd

I found the solution here https://bbs.archlinux.org/viewtopic.php?id=238367

Essentially, I added the following kernel parameter

amd_iommu=off

Since I did not have this problem before, and I have this graphics card for about a year, this must have been caused by a kernel update, but that is another story...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.