In pursuit of an answer to this question, I purchased a Dell WD19TB dock for my XPS 13 7390 "Developer Edition" running 18.04.3 LTS. After connecting everything, the HDMI external monitor works fine, but the USB 3 and gigabit ethernet ports don't work at all. I looked at my devices->Thunderbolt, and the dock shows up as "pending":


I clicked on the dock name in that screen and this dialog popped up, asking me to "authorize and connect" to the dock:


I click the "authorize and connect" button, and after typing in my sudo password, I got another dialog stating "Failed to authorize device: kernel error."


After this, back on the devices->Thunderbolt screen, the dock shows with an error:


Dell support has no idea what to do with Ubuntu users, it seems, and directed me to the official Ubuntu forum, where I will be posting as well. Do I need to install some drivers for the dock? If so, what drivers and where do I get them? How do I get a Dell WD19TB dock working with my system?


I figured this out, mostly by accident. In the BIOS, there are several settings related to Thunderbolt. One is "Thunderbolt Security Level," which defaults to "User Authorization." I changed this setting to "No Security," reconnected the dock, booted it up, and now it sees everything that is connected to the dock.

BIOS Thunderbolt Security

Now, when I look in "Devices -> Thunderbolt," the dock shows up as "Authorized."

Thunderbolt Authorized

Hope this helps someone in the future.

  • Thank you. This applies to Windows too. Screenshot from my Dell Precision 5540 BIOS.
    – xinthose
    Aug 28 '20 at 17:48

Had a similar issue with a Lenovo ThinkPad. Solved it by clicking unlock button on the settings window, then did the steps described above again.

(if the "authorise and connect" button is missing, reboot the machine).

  • Thanks, Conor O'D. This is definitely some sort of weird permissions issue disconnect between the Gnome interface and the system. I clicked the "unlock" and went through the steps again, but have the same result: "Authorization error."
    – AJ.
    Dec 13 '19 at 15:17

I had a similar issue, I resolved by:

boltctl authorize <UUID>


boltctl enroll <UUID>

In my case enroll was needed, in order to not have to 'reauthorize' the device every next session.

  • how do you now UUID?
    – Michael D
    Jul 27 '21 at 13:15

I have a 7380 and had similar problems (on Fedora, though, not Ubuntu)... plugged in the dock and... only power worked. I had no idea "thunderbolt authorization" was a thing until I saw this question. Well, I'm also running KDE and have nothing like the "thunderbolt devices" shown in the question, so I asked my package manager for anything related to "thunderbolt". Apparently the only thing Fedora packages is the CLI boltctl. (I wouldn't be surprised if the GUIs are using boltctl under the hood.)

Installed and ran that (no arguments yet), and wham, display turns on. (Possibly the only reason the display didn't work immediately is because I didn't have boltctl installed previously. Running boltctl obviously gave the TB bus a needed kick.) Still no USB though, but I'm not done yet. A quick boltctl authorize <UUID>, and now everything is working, no BIOS fiddling required.

This may depend on what kernel version you're running; I read somewhere that thunderbolt authorization stuff was added in 4.13. I'm running 5.5. It may be that authorization doesn't work on older LTS versions.


Same in my Ubuntu 19.10 with Benq dock ethernet, but today it worked in Kubuntu 20.04. (Too bad external microphones are broken now.) I guess it's a kernel issue.

$ uname -a
Linux cees-XPS-13-9380 5.4.0-31-generic #35-Ubuntu SMP Thu May 7 20:20:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.