4

When I want to write f^(-1) on my keyboard it comes out as f⁽⁻¹⁾. More precisely:

Pressing ^ on my keyboard "exponentiates" the next letter I press, such that:

Pressing f ^ ( ^ - ^ 1 ^ ) on my keyboard gives f⁽⁻¹⁾

Since I write papers in LaTeX, this is unacceptable to me. I want to press

f ^ ( - 1 ) and get exactly f^(-1), but instead I get f⁽-1)

I'm on Ubuntu 19.10 and when I installed it I chose the danish keymap.

Note: It does so in every editor/program I've tried: gedit, Terminal, LibreOffice, AskUbuntu, firefox, everywhere.

  • 2
    Actually, I learned something new! My US Int keyboard layout does the same. For US keyboard, there are variants, including one without dead key. So check whether there are variants for Danish as well that does not include dead keys. – vanadium Dec 10 '19 at 21:12
  • I can reproduce in gedit. – guillermo chamorro Dec 10 '19 at 21:20
  • .. spanish layout – guillermo chamorro Dec 10 '19 at 21:22
  • 1
    Changing to US English Keyboard solves the problem, so you are right. It must be a (stupid) feature of the danish keymap. – Tom Dec 10 '19 at 21:34
  • 1
    Please consider writing your own answer below. Then after the required waiting period, accept your answer as correct by clicking on the grey check mark and turn it green ✅. This will help others. – user68186 Dec 10 '19 at 21:45
2

As I can replicate this in my spanish layout, found the trick:

After writing the ^ symbol, press the Space bar, to disable the superscript.

  • That works in the danish layout aswell. – Tom Dec 10 '19 at 21:53
1

Note that this is about the danish keymap!

Pressing ^ twice stops it from making the next letter into a superscript.

Apparently, other keymaps, such as US English Keyboard, don't have this "feature".

  • 1
    I tried "Danish (no dead keys)" keyboard layout and it does not have this feature. It took me a while to find the ^ on this layout though. – user68186 Dec 10 '19 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.