3

I am attempting to pair an Apple Magic Keyboard 1 to Ubuntu 18.04 LTS on an MSI GS65 Stealth.

I followed the procedure outlined in this post: http://freewisdoms.com/apple-wireless-keyboard-on-ubuntu/

I used sudo bluetoothctl and was able to trust and pair with the keyboard and get the pairing successful message. I rebooted and checked paired-devices in bluetoothctl and the keyboard is indeed listed.

However, the laptop still doesn't seem to respond to typing on the wireless keyboard. Any advice on how I can solve/debug this issue?

I have looked at the following questions but they either seem involve issues with pairing not working at all (as opposed to the paired keyboard just not working) or different versions of ubuntu/linux.

How to make my Bluetooth keyboard work with Ubuntu 18.04?

Apple keyboard a1016, pairing fails

Apple Magic Keyboard 2, not working properly over bluetooth (16.10)

Bluetooth keyboard paired but not responding 16.04

4

I got the same problem in Feb. 2020, with Ubuntu 18.04 and Apple Magic Bluetooth Wireless Keyboard.

TL;DR: When Apple Magic Keyboard connected, it automatically activates the Num Lock mode. One needs to press / disable the Num Lock key (although there is no such key on the Magic Wireless Keyboard, and that was the trick in my case).

The output of bluetoothctl seemed fine:

Device MY:IP:AD:DR:ES:
    Name: Apple Wireless Keyboard
    Alias: Apple Wireless Keyboard
    Class: 0x00002540
    Icon: input-keyboard
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: yes
    LegacyPairing: yes
    UUID: Human Interface Device... (00001124-0000-1000-8000-00805f9b34fb)
    UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
    Modalias: usb:v05ACp0255d0050
    RSSI: -52

I was not able to type on Apple keyboard, but I noticed that when I typed letters I got digits m > 0, j > 1, k -> 2 and so on. This seems that Numlock or numpad was activated when the keyboard was connected.

Indeed, check it with the Settings > Region & Language > Input Sources and press the Keyboard icon (small keyboard icon).

I saw that Num Lock was active:

indicator

So, I plugged in another keyboard with a Num Lock key, and pressed the Num Lock on that keyboard. Since then, the Apple Magic Keyboard is working normally.

If anybody knows how to generate a Num Lock key event on the system without pressing the key on another keyboard, the script or command would be helpful.

  • If you have a question, ask it. Don't ask in answer. – Gryu Feb 22 '20 at 10:06
  • 1
    Absolutely genius! save me some headache. I used a second USB keyboard to do the switch. – Vlax Apr 29 '20 at 5:22
  • Also saved my arse here, especially since I hadn't found where input sources were hidden. – Dark Star1 Jun 17 '20 at 8:10
  • I haven't tried these solutions myself, but there may be an answer to the numlock issue here - wiki.archlinux.org/index.php/Apple_Keyboard – iainp999 Jun 25 '20 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.