0

I am setting up i3wm. In my config file I put:

exec_always --no-startup-id mate-settings-daemon
exec_always --no-startup-id mate-power-manager   
exec_always --no-startup-id nm-applet

I am using ubuntu Mate 18.04. If I look at these processes I get 2 istances: ps aux | grep mate-settings-daemon
linofex 3003 0.0 0.0 4624 800 ? S 09:37 0:00 /bin/sh -c mate-settings-daemon linofex 3005 0.0 0.5 1340260 42640 ? Sl 09:37 0:01 mate-settings-daemon
where the second line refers to exec in i3 config file.

This happens for all the programs that I put in the config.

The reason why I put nm-applet is to show the icon try on the bar.

I tried to uncheck them in the startup programs applet, but nothing changes

Is that normal, or should I do something to solve?

  • Some of the processes may already be started by XDG autostart, so launching them again after logging into a desktop environment will start them once more (if the app itself does not "notice/check" it is already loaded) – vanadium Dec 10 '19 at 11:45
0

Some of the processes may already be started through XDG autostart. When any user logs in, processes defined in /etc/xdg/autostart are automatically started. That includes the daemons that your desktop environment uses.

These processes are described using .desktop files, text files with the same format as these used to populate the application menu. However, they include a line NoDisplay=true to prevent them from showing up in your menu.

In principle, desktop specific .desktop files also should contain an entry that limits their execution to that specific desktop environment. Such line looks like OnlyShowIn=MATE;. This line will make sure the desktop file is not used (as if it would not exist) except in the listed desktop environments. The system is informed about the current desktop through the environmental variable $XDG_CURRENT_DESKTOP.

Thus, in your i3 session 1) Check whether $XDG_CURRENT_DESKTOP is set or correctly set. 2) Check whether the .desktop file in /etc/xdg/autostart that corresponds with mate-settings-daemon does contain the appropriate OnlyShowIn line.

| improve this answer | |
  • Yes, mate-settings-daemon and mate-power-manager have OnlyShowIn=MATE;. But if I edit these lines and I reboot the session not in i3, but in the classic environment, will these programs start? – linofex Dec 10 '19 at 12:28
  • What gives echo $XDG_CURRENT_DESKTOP? What happens if you comment out exec_always --no-startup-id mate-settings-daemon in i3-config? – vanadium Dec 10 '19 at 15:22
  • Sorry for the delay. echo $XDG_CURRENT_DESKTOP shows i3. If I comment exec_always --no-startup-id mate-settings-daemon then my graphic goes very ugly and ps aux doesn't show either of the two lines linofex 3003 0.0 0.0 4624 800 ? S 09:37 0:00 /bin/sh -c mate-settings-daemon linofex 3005 0.0 0.5 1340260 42640 ? Sl 09:37 0:01 mate-settings-daemon – linofex Dec 17 '19 at 10:25
  • Try changing exec-always to exec, reboot and see whether you still have the 2 processes. – vanadium Dec 17 '19 at 10:59
  • Yes, I still have both – linofex Dec 17 '19 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.