2

The settings app does not open at all. I have tried restarting the computer, uninstalling and reinstalling gnome-control-center. Neither method worked. I don't remember doing anything that may cause this issue.

When I run sudo gnome-control-center from the terminal, this is the result:

**
ERROR:../shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid)
Bail out! ERROR:../shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid)
Aborted
  • Did you try from terminal? – guillermo chamorro Dec 9 '19 at 22:52
  • @guillermochamorro Yep. Gives an error. I've put the details into the original question. – Eletwo Dec 10 '19 at 0:31
  • Just to eliminate a problem with your local account, create a new account... called Guest, or Test, whatever. Then log into that new account and try settings. If it works, let me know and I'll give you further steps. Start comments to me with @heynnema or I may miss them. – heynnema Dec 11 '19 at 19:27
  • status please... – heynnema Dec 12 '19 at 4:31
  • I tried it, didn't work. I ended up wiping my entire partition and installing Kubuntu. Thank you for your help. – Eletwo Dec 12 '19 at 5:51
1

I cannot pinpoint your issue specifically, but I will provide a general comment on what might have been caused your issue.

You ever ran a graphical application just with sudo? Do not say "No", because, in your question, you already mention to have run "sudo gnome-control-center".

You may have done that before with other graphical applications. For years, it is being told that this is a no-go. Running graphical applications with sudo may inadvertently change permissions of files in your home folder, and thus may cause problems when yo try to run a program normally. Problems like you are describing now.

Therefore, I just limit this post with a warning Never use sudo with graphical programs. It is not designed for that. We used to have gksudo but also that way has been depreciated. There are currently two valid ways to run a graphical application as root:

  1. Use the admin:// URI. For example, gedit admin:///etc/fstab will allow you to safely edit fstab with the graphical editor gedit. nautilus admin:///etc will allow you delete a file or change its permissions in a system directory.

  2. Use pkexec. This will work only if a policy file is installed. Policy files typically come with the application. How to create your own policy file is out of the scope of the current question.

How to solve your issue? Setting up a fresh account and use that one certainly will work. However, with some luck, the suggestion of guillermo chamorro to delete some hidden config folders may or may not work. Systematically changing the owner of all hidden files under your home folder, may or may not work.

|improve this answer|||||
  • A little long-winded, but using sudo to open graphic applications really (commonly) only changes two files in the user's home directory (.*authority). Also, sudo -H is the proper way to start graphic applications without this complication. ie: sudo -H gedit filename – heynnema Dec 11 '19 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.