0

So I made a Linux VirtualMachine. I press start it starts alright then i press f12 and choose my language. And finally click on Install Ubuntu and an error pops up Kernel requires Kernel requires x86-64 cpu, but only detected 686 CPU

2
  • I get this error message every so often when I test a x86_64 ISO on a 32-bit box, or VM that is limited to x86/i686/32-bit (even though my host is amd64 - I limit it to x86 to prove the message is appropriate in testing Ubuntu ISO images). Check your host settings aren't limiting VM to x86 instead of amd64. In my testcase - that's message is a successful test
    – guiverc
    Dec 9 '19 at 13:02
  • 1
    Hi @Ridas. The usual issues are either your BIOS does not have virtualization enabled (or may not have it at all depending on the manufacturer), or your host CPU is 32bit architecture. In the former, you can enable VT-X or AMD-V in the BIOS. In the latter, you will need to upgrade your CPU to one with 64bit architecture. This enables your virtual machine to use the 64bit architecture of your CPU. It cannot emulate 64bit on a 32bit CPU. Dec 9 '19 at 13:12
1

There may be two reasons for that:

  1. Your CPU is 32-bit and doesn't support x86-64.

  2. Hardware virtualization is not enabled in BIOS, or isn't supported by the hardware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.