2

Title says it all, basically.

In Digikam, I cannot (I think) access the settings without using the menu bar. All screenshots I see of this program have a menu bar. But on my system, I cannot get it to appear:

enter image description here

The "digikam" dropdown has no useful options.

I would assume this is a basic setting, but I've searched everywhere (settings, gnome-tweaks, gnome-tweak-tool, compizconfig, ...) and cannot get it to appear.

Any help is greatly appreciated, many thanks!

  • did this askubuntu.com/questions/1050378/… work for you? – nobody Dec 12 '19 at 18:15
  • Thanks for the suggestion. I had a look, and it doesn't seem to solve my problem. I've tried installing and enabling the gnome global menu extension, even if it's no longer supported, but the menu bar is still not visible. Also, the post seems to talk mainly about apps that are native to gnome; digiKam is native to KDE. – ElRudi Dec 12 '19 at 23:16
  • Also, the information in that post seems outdated, as the app menu is going away – ElRudi Dec 12 '19 at 23:23
  • Can you show please gsettings list-recursively | grep menubar – nobody Dec 15 '19 at 11:26
  • @ElRudi it isn't outdated yet, because the appmenu is used in the Ubuntu LTS and this is the recommended Ubuntu version to be installed. Also the appmenu is a Gtk3+ feature and not matter if gnome-shell remove the appmenu implementation or not, it continued be part of Gtk3+. So, it's an existent feature anyway, not matter if rigth now notone is using it. – lestcape Dec 17 '19 at 17:40
1
+50

The default key combination to toggle the menu bar for digikam 6.4.0 is Ctrl + M.

|improve this answer|||||
  • Actually, I'll be damned but that works! I'll add it to the list of things to check when searching for menu items. (Which already includes pressing Alt to make the menu bar briefly appear like in Firefox, having an app menu instead of a menu bar like in some gnome native apps, and always having a menu bar present like in Inkscape and Gimp.) I feel a bit stupid haha but in my defence - I didn't see this option when right-clicking on any toolbar, so I didn't think there might be a shortcut for it. I've since learned Ctrl+M is standard (?) in KDE apps, so I'll try it more often. Many thanks!! – ElRudi Dec 15 '19 at 15:16
  • I'm really glad this helped, sometimes the simplest things are easy to overlook! – ofperfection Dec 16 '19 at 0:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.