I'm quite new to Linux in general. And did some "rookie" mistakes...

I tried to install Pi-Hole on my server, and did also install lighttpd (by mistake, I forgot that Apache2 was running).

Now, Pi-Hole web interface somehow does not work, so I attempted a reboot. Which made me lose connection to the server, and thereby SSH won't work anymore...

I'm using bond0 with 2 assigned Ethernets.

The eth1 assigns itself with an IP on every startup, bond0 usually use the assigned static IP (which is supposed to be). eth2 doesn't display any IP address.

Whenever I do run

sudo netplan apply

The server gains connectivity, but

sudo apt update 

still doesn't seem to work. But the eth1 loses its static IP.

Any suggestions on how to fix this issue?


Just figured it out.

"dhcpcd" was also installed, besides Pi-Hole. Which is why eth1 was assigned an IP

I ran these commands:

sudo systemctl stop dhcpcd.service


sudo systemctl disable dhcpcd.service

(Sorry, I don't know how to make headers/blocks!)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.