The brave browser worked great for me for many months. I have discovered several extensions which I enabled carefully including "The Great Suspender" so keeping tabs open doesn't consume unnecessary resources.

Last week after an update when I click the icon in the lxde menu bar I see no windows opening at all.

It's not opening a blank white window like I saw reported elsewhere, just nothing.

I believe I installed using the most current method, not snap. 1.0.1 recently came out.

$ dpkg -l | grep -i brave
ii  brave-browser    1.0.1  amd64   The web browser from Brave
ii  brave-keyring    1.7      all   Brave Browser keyring and repository files

I see it's trying to open but doesn't:

$ ps -ef | grep -i brave
grantbow  4732  4160  0 12:42 ?        00:00:00 /bin/bash /usr/bin/brave-browser-stable
grantbow  4739  4732 28 12:42 ?        00:00:09 /opt/brave.com/brave/brave
grantbow  4743  4739  0 12:42 ?        00:00:00 /opt/brave.com/brave/brave --type=zygote
grantbow  4747  4743  0 12:42 ?        00:00:00 /opt/brave.com/brave/brave --type=zygote
grantbow  4766  4739  4 12:42 ?        00:00:01 /opt/brave.com/brave/brave --type=gpu-process --field-trial-handle=1515
8583491962856952,6341817588596150380,131072 --enable-features=NewExtensionUpdaterService,PasswordImport,SimplifyHttpsIn
dicator,WebUIDarkMode --disable-features=AudioServiceOutOfProcess,AutofillServerCommunication,LookalikeUrlNavigationSug
gestionsUI,NotificationTriggers,SmsReceiver,SyncUSSBookmarks,UnifiedConsent --gpu-preferences=KAAAAAAAAAAgAAAgAAAAAAAAY
AABAAAAEAAAAAAAAAAAAAAAAAAAAAgAAAAAAAAA --service-request-channel-token=5765932197625944813


I looked in ~/.config/BraveSoftware/Brave-Browser/Default but didn't find anything I recognized as relevant.

I saw discussions about enabling a kernel namespace configuration like this github thread but those reports do not seem current and I am not sure a change of that type would have happened recently though it's possible.

My first concern was to backup my settings. I am not sure how to start without extensions. I saw a brave support template on the brave site but not details on how to check my settings or a process by which to narrow down the causes. Without at least a workaround to get an open window I am limited in exploring the settings very well.

Suggestions welcome!

  • perhaps because brave is based on chromium some of the same steps should be followed to narrow down a problem.
    – grantbow
    Dec 8, 2019 at 15:06
  • aha, $ /opt/brave.com/brave.brave will get a window open but it's not using my profile or any of the data I want to find a way to reuse.
    – grantbow
    Dec 8, 2019 at 15:17
  • debug logs are described support.google.com/chrome/a/answer/6271282?hl=en
    – grantbow
    Dec 17, 2019 at 21:25
  • this seems to help get closer to the problem! From a terminal $ /opt/brave.com/brave/brave --type=zygote --enable-logging=stderr --v=1 yields infinite messages like [24784:24784:0100/000000.261653:ERROR:zygote_linux.cc(240)] Error reading message from browser: Socket operation on non-socket (88)
    – grantbow
    Dec 17, 2019 at 21:41
  • a google for "debugging google chrome zygote" lead me to chromium.googlesource.com/chromium/src/+/master/docs/…
    – grantbow
    Dec 17, 2019 at 21:43

1 Answer 1


Remove the Brave completely

sudo apt remove brave

rm -r ~/.config/BraveSoftware

Install Brave

sudo snap install brave

If you don't have Snap activated read here

  • 1
    snap packages of brave are deprecated. brave-browser.readthedocs.io/en/latest/…
    – grantbow
    Dec 12, 2019 at 23:04
  • Not exactly check the release date, it's the last stable release. It may not be updated that frequently but it is updated.
    – JoKeR
    Dec 14, 2019 at 9:00
  • i'm using the most supported ubuntu version installed like other debian/ubuntu packages. I found the last snaps I tried to be not fully integrated with desktop environments yet.
    – grantbow
    Dec 17, 2019 at 21:34
  • your answer also doesn't help me recover the profile data which is important.
    – grantbow
    Dec 18, 2019 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.