Yesterday I did a new installation for my old laptop. I can access the internet via cable, yesterday I was able to access the wifi. Now I see the wifi but I am not able to connect since the network manager keeps asking for the password.

Some extra notes:

  • Wifi works on my phone, the password has been checked.
  • When the problem occurred, I had also two network-manager icons in the task bar. Reading in internet this has been resolved.
  • Already tried to do sudo service network-manager restart did not work.
  • sudo apt purge wl and sudo apt install firmware-b43-installer was also ineffective.
  • Turn on and of the wifi with F12 did not work.
  • I rebooted several times to double check each attempt.
  • Not clear to me why rfkill gives me 2 wireless LAN (see below)
  • I installed Lubuntu, I am not sure why lsb_release shows Ubuntu below.

Below you can find some output of normal commands.

I am not really an expert, can anybody help me further?

ff-HP:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.3 LTS
Release:    18.04
Codename:   bionic
ff-HP:~$ rfkill list all
0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
@ff-HP:~$ sudo lshw -class network
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 02
       serial: 78:ac:c0:cc:a2:a1
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:17 ioport:6000(size=256) memory:f0010000-f0010fff memory:f0000000-f000ffff memory:f2500000-f251ffff
       description: Wireless interface
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Inc. and subsidiaries
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlp4s0b1
       version: 01
       serial: ac:81:12:42:9b:6e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=brcmsmac driverversion=5.0.0-37-generic firmware=610.812 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:19 memory:f1100000-f1103fff
@ff-HP:~$ sudo lshw -short
[sudo] password for xxx: 
H/W path         Device      Class       Description
                             system      HP Pavilion G62 Notebook PC (XF328EA#UUZ)
/0                           bus         143C
/0/0                         memory      1MiB BIOS
/0/23                        memory      4GiB System Memory
/0/23/0                      memory      2GiB DIMM DDR3 Synchronous 1334 MHz (0.7 ns)
/0/23/1                      memory      2GiB DIMM DDR3 Synchronous 1334 MHz (0.7 ns)
/0/2c                        processor   AMD Phenom(tm) II N620 Dual-Core Processor
/0/2c/2d                     memory      256KiB L1 cache
/0/2c/2e                     memory      2MiB L2 cache
/0/100                       bridge      RS880 Host Bridge

1 Answer 1


The problem is solved.

I updated to Lubuntu 19.04 and the problem persisted. Than I performed a sudo service network-manager restart and after rebooting I was able to connect to the wifi normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.