0

I read other questions regarding this issue and went into Terminal to follow the solution, typing, "sudo apt-get install exfat-fuse exfat-utils". This is the error I received, which incidentally also happened near the end of my upgrade to 19.10:

Closed all other Terminal windows and still the same error.

N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?


  • Check you don't have another terminal open that is trying to upgrade/install or do something, but waiting patiently for you to answer a question - thus your 'lock' message. – guiverc Dec 7 '19 at 8:55
  • I closed all other terminal windows and entered the command again but the same message comes up. I don't know what it's waiting for patiently. It's the same error I got at initial upgrade toward the end of the process to 19.10 when I guess it was interrupted somehow. – David Smith Dec 7 '19 at 9:01
  • You mentioned again upgrade to 19.10. If you just completed do-release-upgrade, have you rebooted? Also check text terminals (ctrl+alt+f4 for example) though if you force killed a process, the lock may not have been removed (it gets removed late, thus if kill -9 may have mean it remains locked that session) – guiverc Dec 7 '19 at 9:10
  • I have rebooted since upgrading. I don't at all understand how to look into the rest of what you've written there. – David Smith Dec 7 '19 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.