0

Sound worked fine through speakers using 19.10 Lubuntu for a few days and suddenly stopped working.

I'd upgraded from 18.04 through to 19.10 if that is relevant, which I've read similar questions about sound lost following that upgrade.

My speakers and Youtube (for example...) are both not muted and there is zero sound. I unplugged the speakers and again zero sound.

How do I restore sound to my system?

Thank you.

Update: got this message when following terminal suggestion:

Command 'pavucontrol' not found, but can be installed with:

sudo apt install pavucontrol

I followed the terminal install prompt for pavucontrol even though from the bottom left of my screen in the menu it says I have Pulse Audio (same program, correct?) and it gives me the lock error I received at the end of my upgrade to 19.10 also:

E: Could not get lock /var/lib/dpkg/lock. It is held by process 29189 (dpkg) - open (11: Resource temporarily unavailable)
N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
  • Have you looked in pavucontrol (pulse audio volume control) for any muted devices... Also check in the Configuration (last tab) your profile is currently 'active' (ie. you haven't muted your profile).. – guiverc Dec 7 '19 at 7:28
  • It states, Establishing connection to Pulse Audio control please wait, yet nothing seems to happen. I can see in the lower right corner on volume that it is not muted. It's at 100%. – David Smith Dec 7 '19 at 8:14
  • If you run pavucontrol from terminal, do you get any useful messages you can provide? (edit your question and add there) , I'd also look in logs but I don't see any messages when I enter pavucontrol myself – guiverc Dec 7 '19 at 8:17
0

The error from dpkg is something more serious, you should look into that first. If you got it after the upgrade it is possible that part of your system has not been upgraded and this can cause all kinds of problems.

There are 3 lock files for apt, find out what process uses them like this

lsof /var/lib/dpkg/lock
lsof /var/lib/apt/lists/lock
lsof /var/cache/apt/archives/lock

This should return the PID (Process Identification Number) for the application if the files are currently in use. It can also return nothing, then the process that created the files is no longer active.

If the files are in use, kill the process(es) that uses them like this:

sudo kill -9 PID

PID is the number you found using the previous lsof commands

After that, remove the lock files like this:

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock

and reconfigure dpkg:

sudo dpkg --configure -a

Because of this there might be some updates that you have missed so run your update manager or while you are still in terminal

sudo apt update && sudo apt full-upgrade

To reset the audioserver try this in a terminal:

pulseaudio -D

What I also have found sometimes is this, if your system has audio control keys on it there is usually one key that mutes sound. This sets a flag in firmware that keeps sound disabled across reboots. Perhaps you accidentally pressed this key?

  • pulseaudio -D worked thank you. Is it a permanent solution? – David Smith Dec 7 '19 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.