5

I have successfully installed ubuntu 18.04.3 LTS, and at the beginning i've successfully connected to my wireless network, but after restarting the wifi adapter was not found. I've connected to the internet through lan cable and installed successfully wifi drivers. After that the wifi was fully functional, but after restarting there was the same issue- no wifi adapter. It was really annoying to install wifi drivers on every restart, and if you can help me i will be very grateful. Network adapter is: Intel(R) Wireless-AC 9462 Thanks for helping.

3
  • Had a similar issue on Dell XPS 15 9575, but reboot fixed it. – Taras Khalymon Dec 6 '19 at 14:50
  • Thanks for your respond, but restarting is causing the issue. After restart i have to reinstall driver for wifi. – user1022695 Dec 6 '19 at 15:38
  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Dec 6 '19 at 16:54
4

I had the same problem, but the solution was really different. When you install OS on your computer, secure boot is on. This means that your OS is going to have less abilities including connecting to WiFi. - HOW TO TURN OFF SECURE BOOT? Go to BIOS system. For doing that, you will need to turn off a PC. Every computer developer has its own way to go to BIOS. For example, I have HP laptop. When I start it, I press esc button and get the menu, then press F10 and go to BIOS. So look for your way to get there. Then look through BIOS menu options until you will see "Secure boot" one. Change the value to "Disabled" and save the settings. Then start Ubuntu. That may work, I am not sure, but anyway, try it. Secure boot is default on so it can block your WiFi driver.

1
  • Thanks friend it's working, you've really saved me time and patience. – user1022695 Dec 7 '19 at 17:51
0

Found a similar issue here, maybe it will help you https://askubuntu.com/a/1089238/268965.

Looks like the problem is that wl driver loads and replaces a correct driver. Try doing

# update-initramfs -k all # update all initramfs images
# update-grub

This should load a correct driver to initramfs and problem should be gone

1
  • I have tryed your solution and i really appreciate your help, but sadly it doesn't work. – user1022695 Dec 6 '19 at 15:28
0

Not yet supported in linux kernel shipped with Ubuntu 18.04. You Need to install backport like this to support latest Intel wifi :

sudo apt update
sudo apt install git build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi/
make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
sudo modprobe iwlwifi
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.