0

I've got a Windows 10 + Ubuntu 18.04 dual boot setup on my laptop. Windows in on an SSD, while Ubuntu is on a separate HDD. I normally use Ubuntu for most of my work, and occasionally use Windows for Word, Excel, and other stuff. I normally shutdown Windows after completing my work, and never usually put it into sleep mode.

However, 2 days ago, I needed to use Windows for Rufus and backing up some NTFS drives, and so I used it for a longer time than usual, and kept it open throughout the night, and even put it into sleep mode at some point.

The next time I tried to boot Ubuntu on it, I was greeted with a very weird boot screen. I have disabled Plymouth or splash, whatever its called, so I'm used to a "black screen with text all over it", where the first line is the fsck output.

Normally, the text size is small from the beginning (high resolution), and halfway through the process, the intel-backlight service turns on, so I get a change in brightness while all the text is being written on the screen.

However, this time, the text started out very large (a very low resolution), and I got multiple errors, including failed to load swapfile, failed to mount partition /mnt/ext4-part, and all the network-related services failed to load, due to which the Snappy Daemon failed to load, and I was stuck in the booting process. It also failed to load the color profiles. (Weirdly enough, the output of fsck is perfectly normal and no corrupted files at all...)

I've even tried by commenting out the swapfile and /mnt/ext4-part lines from /etc/fstab through a live disk, but that doesn't seem to solve the problem...

I have an Nvidia graphics card, if that makes a difference, but I use the nouveau open-source driver and not the proprietary one.

Can someone please tell me what may have gone wrong and how to fix it?

  • It sounds like when you were using Rufus, you may have accidentally overwritten a partition (sadly, I've done it accidentally too). You may have to boot from a live USB/DVD and check your partitions are ok maybe? – ThatGuy Dec 6 '19 at 6:48
  • @ThatGuy Yeah, I've checked for that, but there's no problem there, as I'm able to boot into recovery mode in Ubuntu.... It's just that the normal mode booting isn't happening as usual.. – Abhigyan Chattopadhyay Dec 6 '19 at 8:04
0

Can you boot into Windows? If you can, try restarting from Windows instead of shutting down. I've had issues with the Windows fast startup setting blocking Ubuntu from booting somehow and restarting Windows bypasses fast startup.

If this restores normal startup in Ubuntu disable fast startup in Windows.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.