2

attempting to install screenlets on Ubuntu 19, however I can't get some of it's dependencies to install correctly - Package 'python-gnome2'.

sudo apt install screenlets
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 screenlets : Depends: python-gnome2 but it is not installable
              Depends: python-wnck but it is not installable
              Depends: python-gconf but it is not installable
              Depends: python-beautifulsoup but it is not installable
              Depends: python-gnomekeyring but it is not installable
              Recommends: python-webkit but it is not installable
              Recommends: python-rsvg but it is not installable
              Recommends: screenlets-pack-basic but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


sudo apt install python-gnome2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-gnome2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-gnome2' has no installation candidate

Some googling shows 'python-gnome2' package has been deprecated after 18.04 ?

Does anyone knows if some workaround is available or if here is some update that allows Screenlets run on Ubuntu 19 ?

1
  • It's not about that one package, or a workaround. It's about "you have requested an impossible situation." Looks like you broke your package management doing some previous workaround. Fix your package management first, usually by reverting whatever non-Ubuntu or wrong-version source you added. – user535733 Dec 5 '19 at 20:32
3

WARNING: Usually the method below is not recommended at all, but you can continue if you really want to get ScreenLets installed on your system.

We need to add Ubuntu 16.04 LTS repositories to the system:

cat << EOF | sudo tee /etc/apt/sources.list.d/xenial.list 
deb http://archive.ubuntu.com/ubuntu xenial main universe multiverse restricted
deb http://archive.ubuntu.com/ubuntu xenial-updates main universe multiverse restricted
deb http://archive.ubuntu.com/ubuntu xenial-security main universe multiverse restricted
EOF

Then we need to install LibPNG 1.2 from linuxuprising PPA (as the regular deb-based method does not work):

sudo add-apt-repository ppa:linuxuprising/libpng12
sudo apt install libpng12-0

Then we need to add ScreenLets PPA:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 94E58C34A8670E8C
sudo add-apt-repository "deb http://ppa.launchpad.net/screenlets/ppa/ubuntu xenial main"

And finally we will be allowed to install ScreenLets:

sudo apt-get install screenlets-pack-all

and enjoy.

1
  • 1
    works like a charm :) 10x – IdanB Dec 9 '19 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.