0

After turning on my laptop, I found my trackpad not working. I don't have separate mouse on me.

To troubleshoot, I'd need to surf the Internet, but of well I have disabled wifi on computer before turning it off

If I had mouse working, enabling wifi would've been 3 clicks corner->wifi->turn on (automatic log in is enabled), but, due to keyboard navigation in gnome being awful, I don't understand how to repeat those actions in my situation...

Right now I have phone to ask question here, but using it isn't comfortable (and i need to put it charging and not temper with it)

So... Please help?


Also, is there any program that allows to control cursor with keyboard? Would be of great help too

2
  • 2
    super+v or super+m then right arrow then up or down and choose WiFi enter.. or similar..
    – PRATAP
    Commented Dec 5, 2019 at 18:03
  • 1
    or you can make it with terminal command also nmcli radio wifi on
    – PRATAP
    Commented Dec 5, 2019 at 18:04

2 Answers 2

1

Press Ctrl + Alt + T to open your terminal. Now use nmcli command to turn your wifi radio on:

nmcli r wifi on

where r option stands for radio.

If the wifi doesn't connect automatically, follow the steps below.

List the available WiFi networks:

nmcli d wifi list

where d option stands for devices.

Now connect to your access point (for example) 'my_wifi':

nmcli d wifi connect my_wifi password <password>

where <password> is the password for the connection.

P.S.

To troubleshoot your trackpad problem, use this wiki.

0
1

I don't know if there is a shortcut but you can do it in the terminal. To disable your wifi adapter use the command rfkill block wifi. To enable it use rfkill unblock wifi. You can also create your shortcuts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .