0

I want to change the default file explorer from nautilus to Thunar. I searched hours around the web and followed all the advices but nothing did work.
What my expected result is: When double-clicking on a folder on the desktop Thunar should open.

My system is VERSION="18.04.3 LTS (Bionic Beaver)"

What I've done so far:

  • I changed all some files (so all files in which nautilus was set to open folder) in /usr/share/applications/ to use Thunar:

    user@computer:/usr/share/applications$ grep -i Thunar * (and exclude the Thunar-Files itself)
    backup-mimeinfo.cache:inode/directory=org.gnome.baobab.desktop;nautilus-folder-handler.desktop;org.gnome.Nautilus.desktop;Thunar-folder-handler.desktop; defaults.list:inode/directory=Thunar-folder-handler.desktop
    defaults.list:x-directory/normal=Thunar-folder-handler.desktop
    mimeinfo.cache:inode/directory=org.gnome.baobab.desktop;nautilus-folder-handler.desktop;org.gnome.Nautilus.desktop;Thunar-folder-handler.desktop;
    nautilus-autorun-software.desktop:TryExec=thunar
    nautilus-autorun-software.desktop:Exec=thunar
    nautilus.desktop:Exec=thunar
    nautilus.desktop:Exec=thunar
    nautilus-folder-handler.desktop:Exec=thunar
    nautilus-home.desktop:Exec=thunar
    nautilus-home.desktop:Exec=thunar
    org.gnome.Nautilus.desktop:Exec=thunar
    org.gnome.Nautilus.desktop:Exec=thunar
    thunar-volman-settings.desktop:Exec=thunar-volman-settings

  • I changed the Mime-Association

    sudo xdg-mime default Thunar.desktop inode/directory application/x-gnome-saved-search

  • I checked the mimeinfo.cache:

    user@computer:/usr/share/applications$ grep inode mimeinfo.cache inode/directory=org.gnome.baobab.desktop;nautilus-folder-handler.desktop;org.gnome.Nautilus.desktop;Thunar-folder-handler.desktop;

  • I changed mimeapps.list in my home-directory:

    user@computer:~/.config$ cat mimeapps.list
    [Added Associations]
    application/x-nautilus-link=Thunar-folder-handler.desktop;
    inode/directory=Thunar-folder-handler.desktop;
    [Default Applications]
    inode/directory=Thunar-folder-handler.desktop
    application/x-gnome-saved-search=Thunar-folder-handler.desktop

But it's still not working. So in principle my only question: How does ubuntu decides what to to when double-clicking on a folder placed on the desktop?

2
  • You might have some settings to configure default applications from a GUI, depending on what desktop environment you're using. If you're on KDE Plasma, then there should be an application called "Default Applications." Dec 5, 2019 at 16:37
  • 1
    You need to set thunar as the file manager that handles the desktop. Currently, it is still nautilus that handles the desktop.
    – vanadium
    Dec 5, 2019 at 17:20

1 Answer 1

0

Ok, thanks to the hint of user vanadium I found out that thunar can not handle the desktop: Question at stackexchange.com

So I have to deal with it...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.