1

I turned on my Aspire One last night and the touchpad was totally non-responsive. To use my laptop, I needed to get a mouse. The touchpad has worked fine for me for more than a year now. I am using Lubuntu 18.04.3 LTS. With the mouse, I was able to use my computer, and write this.

In trying to troubleshoot, I did what others have advised. I ran:

$ cat /proc/bus/input/devices

I got back the following:

I: Bus=0018 Vendor=06cb Product=74a3 Version=0100
N: Name="Synaptics TM2985-009"
P: Phys=i2c-SYN1B82:00
S: Sysfs=/devices/pci0000:00/808622C1:00/i2c-0/i2c-SYN1B82:00/0018:06CB:74A3.0001/input/input5
U: Uniq=
H: Handlers=mouse0 event5 
B: PROP=5
B: EV=b
B: KEY=e520 10000 0 0 0 0
B: ABS=6f3800001000003

I also ran $ xinput list and got back:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Synaptics TM2985-009                      id=11   [slave  pointer  (2)]

I am new at this. From what I can tell, reading online, this indicates that the problem is most likely not with the kernal; perhaps the issue is either with xserver-xorg-input-libinput or xserver-xorg-input-synaptics. I checked, and both are installed on my machine. I also looked up the publishing history for those two; they appear to have been changed on 2019-10-18. That confused me because my touchpad broke only recently. I'm not sure what to do next. I'd like to get this working again.

  • 1
    For now, use an external mouse or the previous kernel (4.15.0-70) as suggested in comment #7 or read the full bug. – DK Bose Dec 5 '19 at 14:02
0

This is most common problem appear when installing updates or installing new linux distribution. And it is due to "linux-kernel-generic" this package, and in this package there are many installed kernel drivers and the latest one which makes crush in my laptop "linux-modules-extra-4.15.0-72-generic".So the only thing you have to do is installing previous versions of this driver.

To remove;

&sudo apt remove linux-modules-extra-4.15.0-72-generic

then the previous version worked for me is; "linux-modules-extra-4.15.0-1007-oracle"

to install it;

$sudo apt install linux-modules-extra-4.15.0-1007-oracle

WARNING; Removing the package and not replacing it results the network not working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.