8

I tried to install the Linux version of NovAtel Convert(OEM6/OEM7) 64-Bit software from this link on my Ubuntu 16.04 machine.

This is the following error I got:

error while loading shared libraries: libxcb-xinput.so.0: cannot open shared object file: No such file or directory

It seems libxcb-xinput-dev is not available in Ubuntu 16.04 xenial according to this page.

Does anyone know how to fix this problem?

3 Answers 3

5

You can reinstall the library like this:

sudo apt install --reinstall libxcb-xinerama0

I had the same error while installing qt6, and reinstalling the library resolved the issue.

1

I had the same issue on Ubuntu 18.04. My solution was running the command sudo apt-get install libxcb-xinput0 to install the missing package.

2
  • E: Unable to locate package libxcb-xinput0 in xenial 16.04
    – doplano
    Dec 5, 2019 at 17:21
  • 1
    @FäridAlijani That's the libxcb-xinput0 package is available in the default Ubuntu repositories only in 18.04 and later.
    – karel
    Dec 5, 2019 at 17:40
0

Use NovAtel Convert 2.5.0 on Ubuntu 16.04

Use NovAtel Convert version 2.5.0, it is the latest version of Convert intended to be used with Ubuntu 16.04.

Versions of Convert after 2.5.0 have been verified for Ubuntu 18.04 and depend on different shared libraries.


How to get NovAtel Convert 2.5.0

You can download older versions of NovAtel Convert by browsing to:

https://files.novatel.com > Software > Convert > 2.x

Or, you can contact NovAtel Applications Engineering for support, by going to: https://novatel.com/contactus/contact-support


Forcing it to work on 16.04

It may be possible to copy over all necessary shared libraries from an 18.04 environment, but it is not recommended because you'd have to copy the files to the exact locations Connect expects them to be at, which are already populated by newer libraries with the exact same file names, in some cases, on 16.04.

It may be possible to make these changes only apply for Convert through use of a chroot jail or union fs. But, that seems like a lot of effort to support two LTS's ago.

Running a Virtual Machine for 18.04 may be a better approach if stuck on 16.04.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .