I bought a computer a couple of months ago wasn't able to make it work so tried again, here is the spec:

When trying to install I got these error messages:

  • nouveau : unknown chipset
  • PCIE bus error: severity=corrected, type physical layer

After installing I was able to reach the login screen, when I move my mouse over my user name to log in, mouse movements are choppy. and after i enter password (also choppy typing) I return to the login screen.

I've spent a lot of hours on this and no success.


  • tried to install for desktop 18.04.03 and 19.10
  • I didn't enable HWE, just downloaded from the official website created ISO and tried to install
    • How do I enable HWE?

How do I make it work?


1 Answer 1


The same happened to me, that's a problem related to the NVIDIA Kernel Module failing with proprietary drivers. To solve it, do the following steps:

  • At the login screen, press ctrl+alt+f2 and login with your name and password
  • Type sudo nano /etc/default/grub (you can change nano to the text editor of your preference, but nano is Ubuntu's default text editor) to edit /etc/default/grub
  • Change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="nomodset"
  • Update this grub edit with update grub
  • Install lightdm using sudo apt-get install lightdm
  • Reboot (you can shutdown throught the terminal with shutdown now)
  • lightdm? This is 19.10, there is no unity. lightdm has been replaced with gdm3 since 2016.
    – darksky
    Dec 5, 2019 at 6:43
  • Well, at least that was the solution that worked out for me (and also for other people). However, I can try the same solution, but without lightdm to see if it still works.
    – victorrms
    Dec 5, 2019 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.