I'm running Ubuntu 11.10 (64-bit) as a VirtualBox guest on a Win7 64-bit host.

When I plug in my Android Epic4g (Galaxy S) both the host and guest see the device properly, however lsusb does not.

When I run dmesg I get the following:

[  361.664219] usb 1-2: new full speed USB device number 79 using ohci_hcd
[  362.428798] hub 1-0:1.0: unable to enumerate USB device on port 2
[  363.313782] hub 1-0:1.0: unable to enumerate USB device on port 2

I get the same type of dmesg message with the USB 2.0 (ECHI) Controller enabled and disabled for the guest OS.

I'm stuck with this one, can anyone help?

  • It's likely a stupid question but... Have you installed guest additions in Ubuntu?. – Javier Rivera Apr 9 '12 at 6:49
  • @Javier Rivera - Yeah I did the guest additions and the USB expansion pack for Virtual Box. I also tried to disable ehci_hcd but no luck with that either. For some reason the VM just cannot enumerate my phone. – ProfessionalAmateur Apr 10 '12 at 3:54
  • Hi! Did you manage to find a solution for this problem? I'm having the same problem after upgrading Samsung Galaxy S2 to ICS 4.0.3. – miha May 18 '12 at 9:32
  • @miha - no I gave up. I even upgraded my BIOS firmware and had no luck. There is a possibility it is because Im running Ubuntu in a VM and not as the host OS. In a month or two I'll switch the OS's so linux is the host and win7 is the guest and see if that helps. – ProfessionalAmateur May 18 '12 at 15:22

ProfessionalAmateur, I solved my problem. I am using vmware Fusion, but you can perhaps find an equivalent solution for VirtualBox. See my question and my answer to that question here: https://askubuntu.com/a/138844/64225

|improve this answer|||||
  • @miha- That is very interesting. How did you know the exact values? I'll dig around and see if there is a similiar place to put that for VirtualBox – ProfessionalAmateur May 18 '12 at 21:20
  • 1
    I looked at vmware.log in my Ubuntu.vmware directory and I saw how Android device gets connected with code and pid (pid is the last number). I guess pid varies whether you connect mass storage or something else. – miha May 20 '12 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.