11

I have a local developer environment running MySQL server 5.7.27. I used MySQL Workbench 6.3.10 (this is the latest version AFAIK before 8.0 appeared) without any problem. However when I upgrade to MySQL Workbench 8.0.18 and try to connect to the exact same local server, I get an error:

Failed to Connect to MySQL at 127.0.0.1:3306 with user root
SSL connection error: error:1425F102:SSL
routines:ssl_choose_client_version:unsupported protocol

This is not a problem with root access since I can connect to the exact same server without any configuration change whatsoever with the 6.3.10 workbench. Also not a problem with 127.0.0.1 I believe for the same reason.

Maybe it's something with OpenSSL? But I cannot see enough info in logs. Most I got is [Note] Bad handshake in the /var/log/mysql/error/log. Consequently, if I turn off the SSL connection (forcing unencrypted connection), the Workbench can connect. So it's clearly some mismatch between Server 5.7.2x and the 8.x Workbench, but why?

I installed the 18.04 LTS version of the Workbench 8.0.18, and let's say my Ubuntu is like that as well (it's a derivative).

2
  • So since this is only for local developer purposes, and right now my workaround is to simply disable SSL and connect without SSL. It's only self contained in my local system anyway.
    – Csaba Toth
    Dec 22, 2019 at 21:37
  • 1
    Same issue for me on 20.04 (Pop!_OS). Getting the unsupported protocol error. When I disable SSL I am able to connnect.
    – roerjo
    Apr 24, 2020 at 16:05

3 Answers 3

17

Ok, as pointed out in several places, the issue is related to that your client only allows to speak to TLS 1.2 or higher, as is required on new Ubuntu versions and software, but your server is only TLS 1.1. And is not allowed.

You can update the server to a newer version of MySQL that allows TLS 1.2, or if this is now a big problem, the only solution is to turn off encryption on your workbench. For this purpose, on your workbench connection, go to SSL, and set Use SSL "no". This must be only a temporal solution, as removing SSL is not recomended for security issues. But at least, you can connect to your server.

Disabling SSL encryption on MySQL workbench

2
  • Changing "Use SSL" to No worked perfectly. Mar 9, 2022 at 16:14
  • But be careful with the consecuences of not using SSL...
    – King Midas
    Mar 10, 2022 at 9:13
1

I am facing a similar issue while exporting data from the workbench. I am connecting to the AWS RDS instance using SSH. The connection is successful but I get issue in export. Export does not work on the specific MySQL instance i.e 5.7.19, it works for 5.7.22. Disabling SSL for local MySQL solves the problem. See https://bugs.launchpad.net/ubuntu/+source/mysql-8.0/+bug/1872541 for your reference.

1

This worked for me:

  1. uninstall MySQL workbench (lastest version)
  2. install MySQL workbench 8.0.20

link: https://downloads.mysql.com/archives/workbench/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.