1

As stated in the title, 19.10 is installed and runs well on my Thinkpad X1 Extreme Gen 2 notebook PC. However, I can't get external displays to work through my Thunderbolt 3 docking station.

My mouse and keyboard connected to the docking station both work, and Ubuntu sees both external monitors connected through the docking station (they are listed under devices and I can attempt to use them). However, even though I have used boltctl to confirm the Thunderbolt dock is enrolled and authorized, the displays don't work.

I saw something somewhere that stated that enabling "BIOS Assist Mode" might help, however I am unable to change that setting in the BIOS (perhaps because Windows is controlling it).

Does anyone have any additional ideas?

Additional information:

Docking station model: ThinkPad Thunderbolt 3 Workstation Dock/Thunderbolt 3 Dock Gen 2 - Type 40AN

Additional troubleshooting: I do not have a Thunderbolt to Display Port cable to test with, however HDMI directly into the laptop works fine. Attempting to use HDMI from the Thunderbolt dock does not work.

  • 1) What's the make and model of the dock? I've seen docks work AOK with USB but fail with Thunderbolt 3, so I feel obliged to ask. 2) If you bypass the dock and attach directly from laptop to just one monitor (as in page 10 of download.lenovo.com/pccbbs/mobiles_pdf/…) , does that work, checking each monitor? Please click edit and add those facts to the question. Please do not use Add Comment; instead, please use edit. – K7AAY Dec 3 at 22:27
  • A Dell user updated UEFI & firmware for his dock and then after reboot, it worked. You should be able to update from withing Ubuntu. fwupd.org/lvfs/devices UEFI & Dock updates: ubuntuforums.org/showthread.php?t=2431141 – oldfred Dec 3 at 22:52
  • @oldfred : To test fwupd do I just need to run the same commands that you recommended in that post? (sudo fwupdmgr get-devices sudo fwupdmgr get-updates) . I looked through the list of updates on the page for Lenovo devices and I see things for the X1 Extreme, but I do not see anything specifically listed as being for the X1 Extreme Gen 2. I have never used this utility and so want to clarify, if I run those commands it should look at my hardware and only pull updates specific to my laptop, correct? – John Noonan Dec 4 at 16:18
  • That is my understanding. My system is not yet supported, so have not run those commands. IF when you get devices, if not shown then I would expect update to not run. But if it supported older version, I would then they should also support newer versions. It is more that old systems are not added. – oldfred Dec 4 at 16:22
  • Thank you. I will try that a little later today. I will run fwupdmgr get-devices and if it lists stuff for me I will run it with "get-updates". – John Noonan Dec 4 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.