I have just installed Ubuntu server 16.04 LTS in my virtualbox machine, but I cannot install any new packages? I tried to remove source lists, and update but the same probleme was repeted. I tried this commandes line but ths same probleme.

sudo apt-get clean
sudo apt-get update 
sudo apt-get upgrade --fix-missing

Output of update is :

Err:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
  Temporary failure resolving 'security.ubuntu.com'
Err:2 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
  Temporary failure resolving 'fr.archive.ubuntu.com'
Err:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease
  Temporary failure resolving 'fr.archive.ubuntu.com'
Err:4 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease
  Temporary failure resolving 'fr.archive.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://fr.archive.ubuntu.com/ubuntu/dists/xenial/InRelease  Temporary failure resolving 'fr.archive.ubuntu.com'
W: Failed to fetch http://fr.archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease  Temporary failure resolving 'fr.archive.ubuntu.com'
W: Failed to fetch http://fr.archive.ubuntu.com/ubuntu/dists/xenial-backports/InRelease  Temporary failure resolving 'fr.archive.ubuntu.com'
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/InRelease  Temporary failure resolving 'security.ubuntu.com'
W: Some index files failed to download. They have been ignored, or old ones used instead.

Thanks in advence

  • What output did you get from sudo apt-get update as no output shows a problem as you have no sources available. (FYI: You've tagged lubuntu which is EOL for 16.04 LTS, only Ubuntu server (no desktop), Ubuntu desktop (Unity 7), Kylin or Ubuntu Core 16 are still supported, all flavors are EOL. The output from sudo apt-get update is where I'd look first for clues though. – guiverc Dec 3 '19 at 10:29
  • 1
    Please don't provide additional information in comments, edit your question and add extra detail there. Greater formatting is allowed in questions/answers, it's easier to read etc.... – guiverc Dec 3 '19 at 10:33
  • 1
    You have a temporary network issue, which on a VM usually means problems with the host setup in my experience (it's disabled, wrongly configured, etc). It could also be you're behind firewalls, proxy .... but I'd check your host first. – guiverc Dec 3 '19 at 10:35
  • Updated thanks ! – khelili miliana Dec 3 '19 at 10:36

It seems is just a stupid mistake I have done, I'have forgot to add DNS server name in my interfaces configurations, so all my packages can't resolves a domaine names.

Solution was :adding the line


on the file /etc/network/interfaces

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.