4

One of the software I want to run needs GLIBC_2.27, and all I see is this error on the console:

/lib/x86_64-linux-gnu/libm.so.6: version 'GLIBC_2.27" not found

When I run this command ldd --version I get this output:

ldd(Ubuntu GLIBC 2.23-0ubuntu11) 2.23

How can I update GLIBC to 2.27 and get rid of the above error?

  • 1
    I've seen references to this problem here: askubuntu.com/questions/1143268/…. If you want to try it, here's the direct download link to v2.27: archive.ubuntu.com/ubuntu/pool/main/g/glibc/…. – ajgringo619 Dec 3 '19 at 2:26
  • 1
    Just don't uninstall libc6 from your system. Do a dry run of apt-get purge instead and measure the risks. It is better not to mess with such packages because they will render the system completely unusable and unbootable. Newer versions of libc6 might be incompatible with your system. – kortewegdevries Dec 3 '19 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.