6

I use Ubuntu 19.10 for 2 weeks now and I like it so far except that I have one little problem: The per-installed Firefox does not allow me to play DRM content media (and possible other media too).

i.e.

  • I cant play Spotify in Firefox. It gives me a DRM error.
  • Some youtube videos won't play giving me this error: screenshot YouTube
  • I also try to watch recorded lectures from my university but there too I get an error... I dont think the university uses DRM content screenshot videoplayer

Widevine by google and OpenH264 are both installed and DRM content is enabled in settings.

So I suspect it has to do with HTML5 video, anyone knows a fix?

8
  • 1
    Is DRM enabled in FF settings?
    – Pilot6
    Dec 1, 2019 at 18:41
  • Yes. It is enabled
    – ilivss
    Dec 1, 2019 at 18:46
  • Can you play videos in Chrome?
    – Pilot6
    Dec 1, 2019 at 18:47
  • Just installed Chromium. Youtube works, university video's work but spotify did not work. With spotify I still see the DRM error, even though it is enabled in Chromium settings
    – ilivss
    Dec 1, 2019 at 18:56
  • I suggest installing Chrome. Many sites don't support FF.
    – Pilot6
    Dec 1, 2019 at 18:59

4 Answers 4

5

Run the following commands

sudo apt install libavcodec-extra
sudo apt install ubuntu-restricted-extras

then restart Firefox. Solved the problem for me on Spotify and Netflix.

Credits goes to this Reddit post: https://www.reddit.com/r/Ubuntu/comments/e4mc98/firefox_cant_play_drm_content_on_ubuntu_1910/

0

What solved this problem for me was to stop the tracking blocker. Enabled DRM content and still wouldn't play, then realized the tracking blocker was enabled and stopped that, and everything plays. SO: enable DRM content in the settings, then disable the tracking blocker, and you should be fine. There's no difference between FF and chrome as far as DRM content is concerned, per se.

0

I needed only this command (part of Pierre-Antoine's answer):

sudo apt install libavcodec-extra
0

If you have a customized linux kernel, check the CONFIG_SECCOMP option. It should be enabled.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.