1

I have automatic exposure set, but it reacts very slowly and sometimes not at all (but with cheese it works fine). I'm taking timelapse pictures with following command:

ffmpeg -f video4linux2 -s 1280x720 -i /dev/video0 -vf drawtext="fontfile=/usr/share/fonts/truetype/dejavu/DejaVuSansMono.ttf:text='%{localtime\:%T}':x=20:y=20:fontcolor=white" -vframes 1 $(date +%Y-%m-%d-%H-%M-%S).jpg

So, my question is, how to trigger the exposure adjustment like in what cheese does (but in terminal)?

$ v4l2-ctl -L brightness 0x00980900 (int) : min=-64 max=64 step=1 default=0 value=0 contrast 0x00980901 (int) : min=0 max=50 step=1 default=0 value=0 saturation 0x00980902 (int) : min=0 max=100 step=1 default=55 value=55 hue 0x00980903 (int) : min=-100 max=100 step=1 default=0 value=0 white_balance_temperature_auto 0x0098090c (bool) : default=1 value=1 gamma 0x00980910 (int) : min=100 max=300 step=1 default=100 value=100 power_line_frequency 0x00980918 (menu) : min=0 max=2 default=2 value=1 0: Disabled 1: 50 Hz 2: 60 Hz white_balance_temperature 0x0098091a (int) : min=2800 max=6500 step=10 default=4500 value=4500 flags=inactive sharpness 0x0098091b (int) : min=0 max=10 step=1 default=2 value=2 backlight_compensation 0x0098091c (int) : min=0 max=4 step=1 default=1 value=1 exposure_auto 0x009a0901 (menu) : min=0 max=3 default=3 value=1 1: Manual Mode 3: Aperture Priority Mode exposure_absolute 0x009a0902 (int) : min=5 max=10000 step=1 default=166 value=5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.