0

I recently installed Ubuntu 18.04.3 LTS on my Dell G3 15 that has Nvidia Geforce GTX 1050Ti Mobile. Following the procedures and ways to install Nvidia drivers, I came across the following:

1) GUI Method: Through "Software and Updates" utility, under "Additional Drivers"

2) Command Line: using the command sudo ubuntu-drivers devices followed by sudo ubuntu-drivers autoinstall

3) via PPA: using the command sudo add-apt-repository ppa:graphics-drivers/ppa followed by the same sudo ubuntu-drivers devices

I followed the third procedure, as others were non-free but this showed the ndivia-driver-440, being the latest as recommended and was free.

sudo ubuntu-drivers devices

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C8Csv00001028sd0000086Fbc03sc02i00
vendor : NVIDIA Corporation
model : GP107M [GeForce GTX 1050 Ti Mobile]
driver : nvidia-driver-430 - distro non-free
driver : nvidia-driver-410 - third-party free
driver : nvidia-driver-390 - third-party free
driver : nvidia-driver-415 - third-party free
driver : nvidia-driver-440 - third-party free recommended
driver : nvidia-driver-435 - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin

Finally it asked me to enter a pass as I had my "Secure boot" enabled, saying it will be required upon the reboot. Although the installation fairly well without any hiccups, the thing I do not understand is when I had rebooted and saw Nvidia X Server Settings in my application, starting it showed only the "Prime Profiles" section on the left pane and it did not show other options. Also, even though I had selected Nvidia under the profile section, the Ubuntu>Settings>Details>About still shows "Intel UHD Graphics 630" as the display driver:

enter image description here

enter image description here

And finally, when I used the terminal to see the display details. I got this: enter image description here

Normally, the output of this command shows "drivers" in "configuration" before "latency", just as it does for Intel showing "i915" but it did not show any drivers for Nvidia. Also, the display showed to be UNCLAIMED.

Was there something I missed in the installation of the drivers, and what can I do to properly install them? I would also want to install the Nvidia cuDNN, so any help in installation of that would also be greatly appreciated. Thanks!

  • Please don't provide pictures of text, text is much easier to read (when not a picture), plus we can copy/paste detail from text to use to look up details for you and to respond to you. Why did you tag 14.04? – guiverc Nov 30 '19 at 12:17
  • 1
    Disable Secure Boot. – Pilot6 Nov 30 '19 at 15:49
  • 1
    Thank you @Pilot6, Disabling Secure Boot solved the problem... – Muhammad Waqas Kayani Dec 1 '19 at 4:02
  • And @guiverc, sure. I will keep that in my mind the next time I try to post. :) And I had to tag 14.04 because it did not show 18.04 in the list that shows tags while searching. Plus, is there any way I can edit my post, so that it can get better? – Muhammad Waqas Kayani Dec 1 '19 at 4:06
  • You should be able to edit your own posts; and whilst I've never asked a question here (so have no experience from your end) I thought you could type a tag & it'd suggest one (ie. I'd expected on entering "18." you'd be offered 18.04 & 18.10) The list favors most used tags & 14.04 was topical for 5 years, thus more used than 18.04 with less than 2 years of life so far – guiverc Dec 1 '19 at 4:16
0

You need to disable Secure Boot to load Nvidia proprietary drivers, or sign them that is not quite straight forward.

See THIS QUESTION for more details.

Also note that ALL proprietary Nvidia drivers are non-free. They are erroneously shown as "free" from a PPA.

|improve this answer|||||
0

Properly manual install using the Official Nvidia.run driver step by step. Also solves the booting problems: Starting User Manager for UID 121... and /dev/sda1: clean

1- Identify your Nvidia VGA card.

$ lshw -c display

2- Download the Official Nvidia driver.

Rename the file to ndriver.run (optional, for simplification)

3- The following prerequisites are required to compile and install Nvidia driver:

$ sudo apt install build-essential libglvnd-dev pkg-config

4- Disable Nouveau driver.

$ sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nouveau.conf" $ sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nouveau.conf"

Confirm the content of the new modprobe config file:

$ cat /etc/modprobe.d/blacklist-nouveau.conf blacklist nouveau options nouveau modeset=0

5- Reboot the system.

$ reboot

6- Open the TTY terminal bypassing the black screen errors.

After the BIOS screen, at the Ubuntu's purple screen press **Esc** select **Advanced options for Ubuntu** select the second line: **(recovery mode)** select **root** and press **double Enter**

7- Stop the current display server. Yeah, Nouveau is alive...

$ sudo telinit 3

8- Run the Official Nvidia driver.

$ sudo bash /home/username/Downloads/ndriver.run note: respect uppercases

You should select the affirmative option in all cases. for more information about each step on this guided installation process, read this.

9- Reboot the system.

$ reboot

If everything done right, you should see your graphic card model on Configuration/About window.

|improve this answer|||||
  • 1
    This is a bad idea to install from .run files. You'll have to re-install after each kernel upgrade. All nvidia drivers are available from Ubuntu repos or PPA. They are properly set there for using on Ubuntu. – Pilot6 Dec 1 '19 at 15:31
  • And also note that OP's problem was quite different and it has been solved. – Pilot6 Dec 1 '19 at 15:32
  • Disabling the secure boot wasn't a good solution. – rck368 Dec 1 '19 at 15:41
  • And what is your solution? Without disabling Secure Boot Nvidia driver won't load no matter how you install it. – Pilot6 Dec 1 '19 at 15:43
  • The step 8 solves this issue, if you have time I encourage you to read the Nvidia installation guide. – rck368 Dec 1 '19 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.