A few days ago I noticed, that Transmission in my Ubuntu 10.04 machine suddenly couldn't download anything anymore. To overcome this I have uninstalled and reinstalled Transmission and tried downloading with other clients (Deluge, Vuze) well seeded torrents (ubuntu iso images for example) without success. On the same computer I have also installed Ubuntu 10.10 and Windows 7, which I rarely use. What makes the problem I encounter weirder, is the fact that downloading via torrents works fine in my Ubuntu 10.10 and Windows partitions but not in Lucid Lynx. Browsing the web for similar problems didn't give me answers. Any help would greatly appreciated.

  • You might have gotten a different IP address which would break any custom firewall rules you have for forwarding traffic to your computer. But this would only apply if you did manual traffic routing based on your IP address... – David Oneill Apr 5 '12 at 18:29
  • Where are you receiving your internet from? Are you located in a dorm, have shared internet access, etc? Or do you have your own internet access? – RSX-1327 Apr 5 '12 at 18:30
  • I am sorry I didn't respond earlier. Unfortunately I was unavailable. – Vasilis Baltikas Apr 6 '12 at 6:11
  • I am sorry I didn't respond earlier. Unfortunately I was unavailable. @RSX-1327: I have my own Internet access at home via a Thomson TG585 v.8 modem/router, to which another laptop occasionally wirelessly connects to the Internet. – Vasilis Baltikas Apr 6 '12 at 6:25
  • @ David Oneil I am sorry I didn't respond earlier. Unfortunately I was unavailable. I didn't apply manual traffic routing prior to the incident, although I tried manual port forwarding for Transmission in my attempt to solve the problem. Because this approach was unsuccessful, I reverted back to UPnP automatic port forwarding. – Vasilis Baltikas Apr 6 '12 at 6:29

The problem is solved. My Peerguardian Linux installation caused all the trouble due to either some kind of a bug or some configuration adjustment I tried but can't remember. This was determined by the use of Wireshark (it informed me that the torrent clients connect to the trackers) and by getting the output of sudo iptables -L in a terminal (the output showed that pgl interfered with my machine's iptables rules). Temporarily terminating the appliance of these rules with sudo iptables -F proved the aforementioned hypothesis. Finally I uninstalled and reinstalled Peerguardian Linux and thus solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.