1

enter image description here

Since I upgraded my system to from Ubuntu 18.04.2 to 18.04.3, Nautilus stopped responding to folder icons (replicate images used as icons in XDG_CONFIG_HOME or a similar location). Suddenly, it doesn't support any customized icon and all my folders icons are gone!

I have tried several ways to fix this issue but i didn't found a sufficient solution

All that I did:

  1. Changing icons with the traditional way (GUI) , selecting the required folder then Alt+Enter (or Ctrl+I), clicking on the folder icon then browsing to the required .png file (new icon) ... and this doesn't do anything

  2. Using

    sudo gio set -t 'string' folder_name 'metadata::custom-icon' 'file:///home/required_icon.png' 
    

    ...and this one return the following message

    gio: Setting attribute metadata::custom-icon not supported

  3. I tried to remove Nautilus, then reinstalled it again, but nothing changes

Please, can anyone help me to fix this?
Really, I can't do the job without customized folder icons...

In the picture I opened the same folder with Dolphin in the left and Nautilus on the right, I want to set a custom icon for each folder in Nautilus as I did with Dolphin, but it doesn't work :-\

6
  • You upgraded from which version? What do you mean with "all my folder icons are gone"? No icons anymore or generic icons? Edit your question to make it as precise as possible.
    – vanadium
    Nov 30, 2019 at 11:23
  • from 18.04.2 to 18.04.3 , i mean they are broken they just appear like the default folder icon Nov 30, 2019 at 11:33
  • How about using folder-color?
    – darksky
    Nov 30, 2019 at 11:33
  • i have recently tried it , and it doesn't work too Nov 30, 2019 at 13:02
  • Tried some icon theme like Papirus ? How did it respond ?
    – user227495
    Dec 1, 2019 at 0:09

1 Answer 1

0

To change the icon of a folder in 18.04.3, you'll have to right click on the folder, click properties, then click the icon in the properties dialog:

enter image description here

And select a custom icon

enter image description here

That's it.

enter image description here

5
  • i have told you that this method didn't work , since the last update that i have did in the few previous days , and any folder that has a customized icon before the update it just returned to the default icon after i updated Dec 1, 2019 at 8:52
  • Hmm. If you go to terminal and run nautilus, when you try to change a folder icon in the new nautilus instance that opens, do you see any error messages being printed in the terminal?
    – darksky
    Dec 1, 2019 at 10:54
  • scripter@scripter-root:~/my files/IGEE/3rd year/L05$ sudo nautilus . [sudo] password for scripter: sys:1: PyGIWarning: Nautilus was imported without specifying a version first. Use gi.require_version('Nautilus', '3.0') before import to ensure that the right version gets loaded. RuntimeError: object at 0x7f15602d4640 of type FolderColorMenu is not initialized Dec 6, 2019 at 14:04
  • It appears folder-color may actually cause this bug. bugs.launchpad.net/folder-color/+bug/1826587. If you have any nautilus extensions installed, try purging them.
    – darksky
    Dec 6, 2019 at 17:49
  • Also if you have any gnome shell extensions installed, try disabling all of them to see if that mitigates the problem.
    – darksky
    Dec 6, 2019 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.