1

The problem

Wifi seems to connect fine after system bootup or reboot, but if I suspend my computer (which is a laptop, so this is happening whenever I close the laptop lid), when the computer wakes, wifi indefinitely attempts to connect and fails.

Details

I've been trying to diagnose what's going on primarily by looking at the output ofjournalctl --follow.

Here's the bad version (where authentication seems to time out every time), which I recorded after opening my laptop from a suspended state:

$ journalctl --follow
-- Logs begin at Thu 2019-11-14 11:44:13 EST. --
Nov 29 10:09:56 polystichum kernel: wlp3s0: authentication with 38:70:0c:3e:a0:c5 timed out
Nov 29 10:09:56 polystichum NetworkManager[9032]: <info>  [1575040196.5416] device (wlp3s0): supplicant interface state: authenticating -> disconnected
Nov 29 10:09:56 polystichum NetworkManager[9032]: <info>  [1575040196.6415] device (wlp3s0): supplicant interface state: disconnected -> scanning
Nov 29 10:09:59 polystichum wpa_supplicant[9052]: wlp3s0: SME: Trying to authenticate with 38:70:0c:3e:a0:c5 (SSID='ARRIS-A0C2-5G' freq=5745 MHz)
Nov 29 10:09:59 polystichum kernel: wlp3s0: authenticate with 38:70:0c:3e:a0:c5
Nov 29 10:09:59 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 1/3)
Nov 29 10:09:59 polystichum NetworkManager[9032]: <info>  [1575040199.5399] device (wlp3s0): supplicant interface state: scanning -> authenticating
Nov 29 10:10:00 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 2/3)
Nov 29 10:10:00 polystichum systemd[1]: NetworkManager-dispatcher.service: Succeeded.
Nov 29 10:10:01 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 3/3)
Nov 29 10:10:02 polystichum kernel: wlp3s0: authentication with 38:70:0c:3e:a0:c5 timed out
Nov 29 10:10:02 polystichum NetworkManager[9032]: <info>  [1575040202.5534] device (wlp3s0): supplicant interface state: authenticating -> disconnected
Nov 29 10:10:03 polystichum NetworkManager[9032]: <info>  [1575040203.0548] device (wlp3s0): supplicant interface state: disconnected -> scanning
Nov 29 10:10:05 polystichum wpa_supplicant[9052]: wlp3s0: SME: Trying to authenticate with 38:70:0c:3e:a0:c5 (SSID='ARRIS-A0C2-5G' freq=5745 MHz)
Nov 29 10:10:05 polystichum kernel: wlp3s0: authenticate with 38:70:0c:3e:a0:c5
Nov 29 10:10:05 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 1/3)
Nov 29 10:10:05 polystichum NetworkManager[9032]: <info>  [1575040205.9801] device (wlp3s0): supplicant interface state: scanning -> authenticating
Nov 29 10:10:06 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 2/3)
Nov 29 10:10:07 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 3/3)
Nov 29 10:10:08 polystichum kernel: wlp3s0: authentication with 38:70:0c:3e:a0:c5 timed out
Nov 29 10:10:08 polystichum NetworkManager[9032]: <info>  [1575040208.5791] device (wlp3s0): supplicant interface state: authenticating -> disconnected
Nov 29 10:10:09 polystichum NetworkManager[9032]: <info>  [1575040209.5787] device (wlp3s0): supplicant interface state: disconnected -> scanning
Nov 29 10:10:12 polystichum wpa_supplicant[9052]: wlp3s0: SME: Trying to authenticate with 38:70:0c:3e:a0:c5 (SSID='ARRIS-A0C2-5G' freq=5745 MHz)
Nov 29 10:10:12 polystichum kernel: wlp3s0: authenticate with 38:70:0c:3e:a0:c5
Nov 29 10:10:12 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 1/3)
Nov 29 10:10:12 polystichum NetworkManager[9032]: <info>  [1575040212.5327] device (wlp3s0): supplicant interface state: scanning -> authenticating
Nov 29 10:10:13 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 2/3)
Nov 29 10:10:14 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 3/3)
Nov 29 10:10:15 polystichum kernel: wlp3s0: authentication with 38:70:0c:3e:a0:c5 timed out

And here's the good version, which I recorded after rebooting my laptop with the wifi disabled and then enabling it after I'd started journalctl --follow:

$ journalctl --follow
-- Logs begin at Thu 2019-11-14 11:44:13 EST. --
Nov 29 10:20:18 polystichum gnome-software[1991]: not handling error failed for action get-category-apps: persistent network error: Get https://api.snapcraft.io/api/v1/snaps/search?confinement=strict%2Cclassic&fields=anon_download_url%2Carchitecture%2Cchannel%2Cdownload_sha3_384%2Csummary%2Cdescription%2Cbinary_filesize%2Cdownload_url%2Clast_updated%2Cpackage_name%2Cprices%2Cpublisher%2Cratings_average%2Crevision%2Csnap_id%2Clicense%2Cbase%2Cmedia%2Csupport_url%2Ccontact%2Ctitle%2Ccontent%2Cversion%2Corigin%2Cdeveloper_id%2Cdeveloper_name%2Cdeveloper_validation%2Cprivate%2Cconfinement%2Ccommon_ids&scope=wide&section=photo-and-video: dial tcp: lookup api.snapcraft.io: Temporary failure in name resolution
Nov 29 10:20:18 polystichum systemd[1]: systemd-localed.service: Succeeded.
Nov 29 10:20:18 polystichum PackageKit[1222]: resolve transaction /231_ecddddcc from uid 1000 finished with success after 421ms
Nov 29 10:20:18 polystichum gnome-software[1991]: hiding category graphics featured applications: found only 1 to show, need at least 9
Nov 29 10:20:19 polystichum PackageKit[1222]: resolve transaction /232_ebdebccd from uid 1000 finished with success after 369ms
Nov 29 10:20:19 polystichum tracker-store[1909]: OK
Nov 29 10:20:19 polystichum systemd[1412]: tracker-store.service: Succeeded.
Nov 29 10:20:19 polystichum PackageKit[1222]: resolve transaction /233_cadbceba from uid 1000 finished with success after 372ms
Nov 29 10:20:19 polystichum gnome-software[1991]: Only 8 apps for popular list, hiding
Nov 29 10:20:23 polystichum systemd[1]: systemd-timedated.service: Succeeded.
Nov 29 10:20:36 polystichum geoclue[1219]: Service not used for 60 seconds. Shutting down..
Nov 29 10:20:36 polystichum systemd[1]: geoclue.service: Main process exited, code=killed, status=15/TERM
Nov 29 10:20:36 polystichum systemd[1]: geoclue.service: Succeeded.
Nov 29 10:20:45 polystichum xdg-desktop-por[1586]: Failed to get application states: GDBus.Error:org.freedesktop.portal.Error.Failed: Could not get window list: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: App introspection not allowed
Nov 29 10:20:48 polystichum gnome-software-service.desktop[2294]: Unable to acquire bus name 'org.gnome.Software'
Nov 29 10:20:50 polystichum gnome-shell[1643]: [AppIndicatorSupport-DEBUG] Registering StatusNotifierItem :1.123/org/ayatana/NotificationItem/software_update_available
Nov 29 10:20:50 polystichum gnome-shell[1643]: [AppIndicatorSupport-FATAL] unable to update overlay icon
Nov 29 10:20:50 polystichum gnome-shell[1643]: [AppIndicatorSupport-FATAL] unable to update overlay icon
Nov 29 10:20:52 polystichum kernel: iwlwifi 0000:03:00.0: RF_KILL bit toggled to enable radio.
Nov 29 10:20:52 polystichum kernel: iwlwifi 0000:03:00.0: reporting RF_KILL (radio enabled)
Nov 29 10:20:52 polystichum systemd[1]: Starting Load/Save RF Kill Switch Status...
Nov 29 10:20:52 polystichum systemd[1]: Started Load/Save RF Kill Switch Status.
Nov 29 10:20:52 polystichum kernel: usb 1-1.4: new full-speed USB device number 5 using ehci-pci
Nov 29 10:20:52 polystichum kernel: usb 1-1.4: New USB device found, idVendor=0a5c, idProduct=21e6, bcdDevice= 1.12
Nov 29 10:20:52 polystichum kernel: usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov 29 10:20:52 polystichum kernel: usb 1-1.4: Product: BCM20702A0
Nov 29 10:20:52 polystichum kernel: usb 1-1.4: Manufacturer: Broadcom Corp
Nov 29 10:20:52 polystichum kernel: usb 1-1.4: SerialNumber: 9C2A7081F312
Nov 29 10:20:52 polystichum mtp-probe[2342]: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4"
Nov 29 10:20:52 polystichum mtp-probe[2342]: bus: 1, device: 5 was not an MTP device
Nov 29 10:20:52 polystichum kernel: Bluetooth: Core ver 2.22
Nov 29 10:20:52 polystichum kernel: NET: Registered protocol family 31
Nov 29 10:20:52 polystichum kernel: Bluetooth: HCI device and connection manager initialized
Nov 29 10:20:52 polystichum kernel: Bluetooth: HCI socket layer initialized
Nov 29 10:20:52 polystichum kernel: Bluetooth: L2CAP socket layer initialized
Nov 29 10:20:52 polystichum kernel: Bluetooth: SCO socket layer initialized
Nov 29 10:20:52 polystichum kernel: usbcore: registered new interface driver btusb
Nov 29 10:20:53 polystichum mtp-probe[2355]: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4"
Nov 29 10:20:53 polystichum mtp-probe[2355]: bus: 1, device: 5 was not an MTP device
Nov 29 10:20:53 polystichum systemd[1]: Starting Bluetooth service...
Nov 29 10:20:53 polystichum bluetoothd[2360]: Bluetooth daemon 5.50
Nov 29 10:20:53 polystichum systemd[1]: Started Bluetooth service.
Nov 29 10:20:53 polystichum systemd[1]: Reached target Bluetooth.
Nov 29 10:20:53 polystichum bluetoothd[2360]: Starting SDP server
Nov 29 10:20:53 polystichum dbus-daemon[941]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.577' (uid=0 pid=2360 comm="/usr/lib/bluetooth/bluetoothd " label="unconfined")
Nov 29 10:20:53 polystichum kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Nov 29 10:20:53 polystichum kernel: Bluetooth: BNEP filters: protocol multicast
Nov 29 10:20:53 polystichum kernel: Bluetooth: BNEP socket layer initialized
Nov 29 10:20:53 polystichum bluetoothd[2360]: Bluetooth management interface 1.14 initialized
Nov 29 10:20:53 polystichum NetworkManager[944]: <info>  [1575040853.0706] bluez: use BlueZ version 5
Nov 29 10:20:53 polystichum systemd[1]: Starting Hostname Service...
Nov 29 10:20:53 polystichum kernel: Bluetooth: hci0: BCM: chip id 63
Nov 29 10:20:53 polystichum kernel: Bluetooth: hci0: BCM: features 0x07
Nov 29 10:20:53 polystichum kernel: Bluetooth: hci0: BCM20702A
Nov 29 10:20:53 polystichum kernel: Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000
Nov 29 10:20:53 polystichum kernel: bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0a5c-21e6.hcd failed with error -2
Nov 29 10:20:53 polystichum kernel: Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0a5c-21e6.hcd not found
Nov 29 10:20:53 polystichum kernel: Bluetooth: RFCOMM TTY layer initialized
Nov 29 10:20:53 polystichum kernel: Bluetooth: RFCOMM socket layer initialized
Nov 29 10:20:53 polystichum kernel: Bluetooth: RFCOMM ver 1.11
Nov 29 10:20:53 polystichum NetworkManager[944]: <info>  [1575040853.1843] bluez5: NAP: added interface 9C:2A:70:81:F3:12
Nov 29 10:20:53 polystichum bluetoothd[2360]: Endpoint registered: sender=:1.186 path=/MediaEndpoint/A2DPSink/sbc
Nov 29 10:20:53 polystichum bluetoothd[2360]: Endpoint registered: sender=:1.186 path=/MediaEndpoint/A2DPSource/sbc
Nov 29 10:20:53 polystichum dbus-daemon[941]: [system] Successfully activated service 'org.freedesktop.hostname1'
Nov 29 10:20:53 polystichum systemd[1]: Started Hostname Service.
Nov 29 10:20:55 polystichum gnome-software[1991]: not GsPlugin error snapd-error-quark:1: Failed to write to snapd: Operation was cancelled
Nov 29 10:20:55 polystichum gnome-software[1991]: not handling error failed for action refine: Failed to write to snapd: Operation was cancelled
Nov 29 10:20:58 polystichum systemd[1]: systemd-rfkill.service: Succeeded.
Nov 29 10:20:58 polystichum NetworkManager[944]: <info>  [1575040858.1624] manager: rfkill: Wi-Fi hardware radio set enabled
Nov 29 10:20:58 polystichum systemd[1]: Starting Load/Save RF Kill Switch Status...
Nov 29 10:20:58 polystichum systemd[1]: Started Load/Save RF Kill Switch Status.
Nov 29 10:20:58 polystichum kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
Nov 29 10:20:58 polystichum kernel: iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
Nov 29 10:20:58 polystichum NetworkManager[944]: <info>  [1575040858.5702] audit: op="radio-control" arg="wireless-enabled" pid=1643 uid=1000 result="success"
Nov 29 10:20:58 polystichum NetworkManager[944]: <info>  [1575040858.5711] manager: rfkill: Wi-Fi now enabled by radio killswitch
Nov 29 10:20:58 polystichum wpa_supplicant[943]: dbus: fill_dict_with_properties dbus_interface=fi.w1.wpa_supplicant1.Interface.P2PDevice dbus_property=P2PDeviceConfig getter failed
Nov 29 10:20:58 polystichum NetworkManager[944]: <info>  [1575040858.6541] sup-iface[0x55a3e0f86920,wlp3s0]: supports 5 scan SSIDs
Nov 29 10:20:58 polystichum NetworkManager[944]: <info>  [1575040858.6548] device (wlp3s0): supplicant interface state: starting -> ready
Nov 29 10:20:58 polystichum NetworkManager[944]: <info>  [1575040858.6548] device (wlp3s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6506] policy: auto-activating connection 'ARRIS-A0C2-5G' (9e0beb06-0d17-4c0f-b878-2a55277edca0)
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6527] device (wlp3s0): Activation: starting connection 'ARRIS-A0C2-5G' (9e0beb06-0d17-4c0f-b878-2a55277edca0)
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6528] device (wlp3s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6559] manager: NetworkManager state is now CONNECTING
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6565] device (wlp3s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6573] device (wlp3s0): Activation: (wifi) access point 'ARRIS-A0C2-5G' has security, but secrets are required.
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6574] device (wlp3s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6578] sup-iface[0x55a3e0f86920,wlp3s0]: wps: type pbc start...
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6617] device (wlp3s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6624] device (wlp3s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6629] device (wlp3s0): Activation: (wifi) connection 'ARRIS-A0C2-5G' has security, and secrets exist.  No new secrets needed.
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6630] Config: added 'ssid' value 'ARRIS-A0C2-5G'
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6630] Config: added 'scan_ssid' value '1'
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6631] Config: added 'bgscan' value 'simple:30:-80:86400'
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6631] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256 FT-PSK'
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6631] Config: added 'auth_alg' value 'OPEN'
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6631] Config: added 'psk' value '<hidden>'
Nov 29 10:21:01 polystichum wpa_supplicant[943]: wlp3s0: SME: Trying to authenticate with 38:70:0c:3e:a0:c5 (SSID='ARRIS-A0C2-5G' freq=5745 MHz)
Nov 29 10:21:01 polystichum kernel: wlp3s0: authenticate with 38:70:0c:3e:a0:c5
Nov 29 10:21:01 polystichum kernel: wlp3s0: send auth to 38:70:0c:3e:a0:c5 (try 1/3)
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6925] device (wlp3s0): supplicant interface state: ready -> authenticating
Nov 29 10:21:01 polystichum wpa_supplicant[943]: wlp3s0: Trying to associate with 38:70:0c:3e:a0:c5 (SSID='ARRIS-A0C2-5G' freq=5745 MHz)
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.6944] device (wlp3s0): supplicant interface state: authenticating -> associating
Nov 29 10:21:01 polystichum kernel: wlp3s0: authenticated
Nov 29 10:21:01 polystichum kernel: wlp3s0: waiting for beacon from 38:70:0c:3e:a0:c5
Nov 29 10:21:01 polystichum kernel: wlp3s0: associate with 38:70:0c:3e:a0:c5 (try 1/3)
Nov 29 10:21:01 polystichum kernel: wlp3s0: RX AssocResp from 38:70:0c:3e:a0:c5 (capab=0x411 status=0 aid=4)
Nov 29 10:21:01 polystichum wpa_supplicant[943]: wlp3s0: Associated with 38:70:0c:3e:a0:c5
Nov 29 10:21:01 polystichum wpa_supplicant[943]: wlp3s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Nov 29 10:21:01 polystichum wpa_supplicant[943]: wlp3s0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=US
Nov 29 10:21:01 polystichum kernel: wlp3s0: associated
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.8243] device (wlp3s0): supplicant interface state: associating -> 4-way handshake
Nov 29 10:21:01 polystichum wpa_supplicant[943]: wlp3s0: WPA: Key negotiation completed with 38:70:0c:3e:a0:c5 [PTK=CCMP GTK=CCMP]
Nov 29 10:21:01 polystichum wpa_supplicant[943]: wlp3s0: CTRL-EVENT-CONNECTED - Connection to 38:70:0c:3e:a0:c5 completed [id=0 id_str=]
Nov 29 10:21:01 polystichum kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.8735] device (wlp3s0): supplicant interface state: 4-way handshake -> completed
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.8736] device (wlp3s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "ARRIS-A0C2-5G"
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.8738] device (wlp3s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.8743] dhcp4 (wlp3s0): activation: beginning transaction (timeout in 45 seconds)
Nov 29 10:21:01 polystichum avahi-daemon[926]: Joining mDNS multicast group on interface wlp3s0.IPv6 with address fe80::2c9b:8eda:7342:9144.
Nov 29 10:21:01 polystichum avahi-daemon[926]: New relevant interface wlp3s0.IPv6 for mDNS.
Nov 29 10:21:01 polystichum avahi-daemon[926]: Registering new address record for fe80::2c9b:8eda:7342:9144 on wlp3s0.*.
Nov 29 10:21:01 polystichum kernel: wlp3s0: Limiting TX power to 27 (30 - 3) dBm as advertised by 38:70:0c:3e:a0:c5
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.9604] dhcp4 (wlp3s0): state changed unknown -> bound
Nov 29 10:21:01 polystichum avahi-daemon[926]: Joining mDNS multicast group on interface wlp3s0.IPv4 with address 192.168.0.9.
Nov 29 10:21:01 polystichum avahi-daemon[926]: New relevant interface wlp3s0.IPv4 for mDNS.
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.9666] device (wlp3s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum avahi-daemon[926]: Registering new address record for 192.168.0.9 on wlp3s0.IPv4.
Nov 29 10:21:01 polystichum dbus-daemon[941]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.14' (uid=0 pid=944 comm="/usr/sbin/NetworkManager --no-daemon " label="unconfined")
Nov 29 10:21:01 polystichum systemd[1]: Starting Network Manager Script Dispatcher Service...
Nov 29 10:21:01 polystichum whoopsie[1091]: [10:21:01] Cannot reach: https://daisy.ubuntu.com
Nov 29 10:21:01 polystichum dbus-daemon[941]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Nov 29 10:21:01 polystichum systemd[1]: Started Network Manager Script Dispatcher Service.
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.9949] device (wlp3s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.9953] device (wlp3s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.9960] manager: NetworkManager state is now CONNECTED_LOCAL
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.9980] manager: NetworkManager state is now CONNECTED_SITE
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.9982] policy: set 'ARRIS-A0C2-5G' (wlp3s0) as default for IPv4 routing and DNS
Nov 29 10:21:01 polystichum NetworkManager[944]: <info>  [1575040861.9993] device (wlp3s0): Activation: successful, device activated.
Nov 29 10:21:02 polystichum gsd-sharing[1804]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit gnome-user-share-webdav.service not loaded.
Nov 29 10:21:02 polystichum gsd-sharing[1804]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit gnome-remote-desktop.service not loaded.
Nov 29 10:21:02 polystichum systemd-resolved[897]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
Nov 29 10:21:02 polystichum systemd-resolved[897]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
Nov 29 10:21:02 polystichum wpa_supplicant[943]: wlp3s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-44 noise=9999 txrate=27000
Nov 29 10:21:02 polystichum NetworkManager[944]: <info>  [1575040862.2098] manager: NetworkManager state is now CONNECTED_GLOBAL
Nov 29 10:21:02 polystichum whoopsie[1091]: [10:21:02] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/1
Nov 29 10:21:02 polystichum whoopsie[1091]: [10:21:02] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/1
Nov 29 10:21:02 polystichum whoopsie[1091]: [10:21:02] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/1
Nov 29 10:21:03 polystichum systemd-timesyncd[898]: Synchronized to time server for the first time 91.189.94.4:123 (ntp.ubuntu.com).
Nov 29 10:21:04 polystichum systemd[1]: systemd-rfkill.service: Succeeded.
Nov 29 10:21:04 polystichum NetworkManager[944]: <info>  [1575040864.4291] dhcp6 (wlp3s0): activation: beginning transaction (timeout in 45 seconds)
Nov 29 10:21:05 polystichum whoopsie[1091]: [10:21:05] online

As you can see, in the second example, it seems like the network connection sets up just fine. Both attempts (good & bad) are using Ubuntu 19.10's wifi set up straight out of the box. It looks like authentication times out in the bad example, but I don't know why that would be happening or how to fix it.

Things I've Tried

I've tried restarting the network manager with sudo systemctl restart network-manager -- that didn't help.

I've tried setting wifi.powersave = 2 in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf as suggested here.

Some system details

$ screenfetch
                          ./+o+-       @polystichum
                  yyyyy- -yyyyyy+      OS: Ubuntu 19.10 eoan
               ://+//////-yyyyyyo      Kernel: x86_64 Linux 5.3.0-23-generic
           .++ .:/++++++/-.+sss/`      Uptime: 24m
         .:++o:  /++++++++/:--:/-      Packages: 1932
        o:+o+:++.`..```.-/oo+++++/     Shell: bash 5.0.3
       .:+o:+o/.          `+sssoo+/    Resolution: 1600x900
  .++/+:+oo+o:`             /sssooo.   DE: GNOME 
 /+++//+:`oo+o               /::--:.   WM: GNOME Shell
 \+/+o+++`o++o               ++////.   WM Theme: 
  .++.o+++oo+:`             /dddhhh.   GTK Theme: Yaru-dark [GTK2/3]
       .+.o+oo:.          `oddhhhh+    Icon Theme: Yaru
        \+.++o+o``-````.:ohdhhhhh+     Font: Ubuntu 11
         `:o+++ `ohhhhhhhhyo++os:      CPU: Intel Core i7-3667U @ 4x 3.2GHz
           .o:`.syhhhhhhh/.oo++o`      GPU: i915drmfb
               /osyyyyyyo++ooo+++/     RAM: 2165MiB / 7643MiB
                   ````` +oo+++o\:    
                          `oo++.      

$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 7 Series/C210 Series Chipset Family KT Controller (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QS77 Express Chipset LPC Controller (rev 04)
00:1f.2 IDE interface: Intel Corporation 7 Series Chipset Family 4-port SATA Controller [IDE mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
00:1f.5 IDE interface: Intel Corporation 7 Series Chipset Family 2-port SATA Controller [IDE mode] (rev 04)
02:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 07)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 96)

$ sudo lshw 
# ... 
description: Notebook
product: 3443CTO (LENOVO_MT_3443)
vendor: LENOVO
version: ThinkPad X1 Carbon
serial: R9X52A4
width: 64 bits
capabilities: smbios-2.7 dmi-2.7 smp vsyscall32
# ... 

Lastly, I should say that my previous setup was Ubuntu 16.04 (which I ran XFCE and I think some of the Xubuntu packages on top of) on this same machine, and I don't think I ever had the same problem there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.